summaryrefslogtreecommitdiff
path: root/dev-python/multidict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/multidict
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/multidict')
-rw-r--r--dev-python/multidict/Manifest2
-rw-r--r--dev-python/multidict/multidict-4.7.6.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/multidict/Manifest b/dev-python/multidict/Manifest
index f33cf1befb01..a1af2f3cea8e 100644
--- a/dev-python/multidict/Manifest
+++ b/dev-python/multidict/Manifest
@@ -1,3 +1,5 @@
DIST multidict-4.5.2.tar.gz 56753 BLAKE2B 01db2ea847e5ef2fbd4eab89c8a6070f3febcb0046be7344469a7e8e6de6a3c2b2af49069e64953dfcac0044d581c6af09eee70eba78dda8cfa9e0d11d3f1947 SHA512 ec66cf3c57e3386e07e45641536a6eeb94e9707d8a0d3b485d22b8687f20282c9115d533c7b0e9fb6dba28b923cf68dd8cdda08c75e78ca4eca2f0c3ec23c58f
+DIST multidict-4.7.6.tar.gz 57710 BLAKE2B f08a45d4ce404dbb64d2561ee2328c0aa3a8fbf65483082c11e5e1554bec23e5c711da2350e241308a1239256b942ef6c420e6e51aef342b380cc01f84d4ca72 SHA512 5f90cb04fe2562884c331018a5002e1370e2596e0afd21e4289ab696847a3028a074bbaa6717b3905161f823f8592d6572475307039f8f97c1ac65aad815a6b0
EBUILD multidict-4.5.2.ebuild 1129 BLAKE2B 017145854cc27f2c1280d8f81fa1fd7204066d36b000c827525d786ee34e78cbd309c7dcba54125dd048973e4a8dc1f16d77206b258e53d7a87a5839e92f481b SHA512 067dc0278f9cdbf3bb61f2ce6530b67000a535d234f010fc6f2066638faef40d9b108c9b0b76dce7a22396b9010b37a41909634386c80e22502f277150133bcc
+EBUILD multidict-4.7.6.ebuild 713 BLAKE2B ed0071dfc91159e76aa760fc63b82d84df1df49d56ed3528971f22d31cc4c57488731961b9888ad1a601fec5deabf8176072ea511ba4d8573d505f3586072eb6 SHA512 936d9fcad53362bce26445211c5bad48b484222f015c51140a5b3b170e75fbfb760d200401019050ea6db441b061712bbad23196e4083eafd8001c8cf0b8ae09
MISC metadata.xml 428 BLAKE2B 3f7c1f816583b35bd0150ae21c61142bbb7ac5b216edb5011bc032410e408f2566801db025c8f6274dafbfc555b0b32aaca2708684a3601ffe8d371b23e0d556 SHA512 edb199503c42c55b838b5338656b41e760c90ec3e81114106dd352e2c3886f0161a0c6ef258c5c0a0728d2420bde5d26dea41b25b030eb947dbacd702cb2b594
diff --git a/dev-python/multidict/multidict-4.7.6.ebuild b/dev-python/multidict/multidict-4.7.6.ebuild
new file mode 100644
index 000000000000..5feb6a64655b
--- /dev/null
+++ b/dev-python/multidict/multidict-4.7.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="
+ >=dev-python/cython-0.28.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't enable coverage or other pytest settings
+ sed -i -e 's:--cov.*::' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}