summaryrefslogtreecommitdiff
path: root/dev-python/msgpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-01 16:14:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-01 16:14:02 +0100
commitaef01e7679692cb2cf9eca0c03865cfd0a4e33c9 (patch)
tree4a000095846b696df937b27f28c2483b902028c7 /dev-python/msgpack
parentfbf0c3d1b463bf45fb0e9f119bec3424d6a44a4f (diff)
gentoo auto-resync : 01:09:2023 - 16:14:02
Diffstat (limited to 'dev-python/msgpack')
-rw-r--r--dev-python/msgpack/Manifest1
-rw-r--r--dev-python/msgpack/msgpack-1.0.5-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/msgpack/Manifest b/dev-python/msgpack/Manifest
index e9dd750e34fe..30129fdebad9 100644
--- a/dev-python/msgpack/Manifest
+++ b/dev-python/msgpack/Manifest
@@ -1,3 +1,4 @@
DIST msgpack-1.0.5.tar.gz 127834 BLAKE2B 3dcf454630021e35d5c6d5ce850d7ac74a6d11d6fe7c7ed07040daa62585bd6b11dc0f68a5b4c4bf20346c25bc23017f79f2d1bad09f175008b184461d0eea5d SHA512 bc3bf27ca7a9204c5ebc009e4a03db4fb48f6c2733bef393aed16652f07ac92c9400258818743245598343c86494d39b39017ab70d7563a5844091eca11a9faa
+EBUILD msgpack-1.0.5-r1.ebuild 1146 BLAKE2B 38ddfe120f23cff00ee22d1daf76f4989a2195093b231edbdbc625014acc3aedeb1f91a8add6c7bb75cbd09446a7c49d87d8ec6f04deeff5ec9583d183a0002c SHA512 5084c8144d376a756490d198413b2183051e7710a6b3eda26e1c758ba54dfcecd013f13f6b6425642007befe4fbb10f58f9ebe56940500545824038cdca04b50
EBUILD msgpack-1.0.5.ebuild 1050 BLAKE2B 9fa7ed4a7cee0aac5f6c93eee16b691f5411f526c89754a5c59a4e3ac7b621309ae02bd7099dd845fb6de8fe293529de36d695cf6ce171218be727450057812f SHA512 4aa2a1809c5de077b774962ffe2a64292a5a8f2cc9edad3bf5fc9e30dae54b735c957b90ca24b2ee965a46595d0d0eb6650a7260538ffe189fc00540fef2e325
MISC metadata.xml 520 BLAKE2B 5facc8e5c11591c6010fe5eef4030e23502b890d15a896ada0c5625e63179887e13206f28695af92b358c56a9f9660767d8b4234c2c8b489cad41fec01af289d SHA512 a62502d0b2ec3da1b21297f4d4e5fee86c206c8d6a2c19d7bffe2a64b4a2fa990edb3ba07bbacccb59ed79efd23fa713a37b8adffa7f0cbc811fc0fa249d9b63
diff --git a/dev-python/msgpack/msgpack-1.0.5-r1.ebuild b/dev-python/msgpack/msgpack-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..209262b770c6
--- /dev/null
+++ b/dev-python/msgpack/msgpack-1.0.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MessagePack (de)serializer for Python"
+HOMEPAGE="
+ https://msgpack.org/
+ https://github.com/msgpack/msgpack-python/
+ https://pypi.org/project/msgpack/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="+native-extensions"
+
+# extension code is relying on CPython implementation details
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.29.30[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove pre-generated cython files
+ rm msgpack/_cmsgpack.cpp || die
+
+ # native-extensions are always disabled on PyPy
+ # https://github.com/msgpack/msgpack-python/blob/main/setup.py#L76
+ if ! use native-extensions ; then
+ export MSGPACK_PUREPYTHON=1
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ rm -rf msgpack || die
+ epytest
+}