summaryrefslogtreecommitdiff
path: root/dev-python/mpmath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-05 23:55:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-05 23:55:49 +0100
commit232a872b2d1f6ba60d91f3ee05b58a5f2449191c (patch)
treeae15ea04212051e03a43180ad961b257089d637d /dev-python/mpmath
parent8679463887b182c233b55d8112534d7d7dcde08b (diff)
gentoo auto-resync : 05:10:2023 - 23:55:49
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/Manifest1
-rw-r--r--dev-python/mpmath/mpmath-1.3.0-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index 207d5b64aea9..30fd5d68ae9a 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1,3 +1,4 @@
DIST mpmath-1.3.0.tar.gz 508106 BLAKE2B 9d4eebbbb6788dd3ee45c8c30068ef3512043dd09ab626cbaf69b0f6bdf057a6e8c53c34e3dda7627db923f0d536a0bebf83916d8942f4dde9546bb8e0046f33 SHA512 a68028150095d743eae9669a0f70cbe6b7bcb4d27dfad6b1a96575f0885ec7306459a2a464117bab18779883ee8b4293502b4bd0ebd8672767e1d08d38f8b202
+EBUILD mpmath-1.3.0-r1.ebuild 832 BLAKE2B 3b8434868ae761df0ee952a5008bb46b5cccf857a5860df0adff0fcbaf64229d939baa73add5785a0ef889489e94bd100397e7b589ec8c365f7889f0ce7a69b4 SHA512 12aefb38d6e34ccba78c58fb8ee739bbdf7b25fc2e4d78b2e04d9e4e7077f88ee9b07902191e3019586e0ae2f0e81d7cb8e7d4cc278b08b1b0d69c69e92cd9c9
EBUILD mpmath-1.3.0.ebuild 837 BLAKE2B 1c453b944bee711238ceda428c19183e6a26e3e4c8498882e875fe1b044c3d4aa037ec8f3f18cd1ff91b79f28fb01534ffd73f5ce394220ec532985ce9c2d035 SHA512 e5493ae3df2583f1d2978098923aabdf153d51185c93d09afd7d06eb00158e87775883db047fa81f6fae7c8c01c93c45dcdac8c55101a8e556eefb63c1899060
MISC metadata.xml 721 BLAKE2B 45ab45adcc349dc01eb416f63384ec6aec0d7d7464823e1fe0bf9c41b58f1e982a37e75c4c4766eab34b0ab2503617986889ff259b425b2846906f8c412049dd SHA512 2a8f981893c5d2d00893a42b78e53c0eb3b34e655b2c4d4b5e6167c5b4b17c1c47a8f17ccc3b03ccb4594b29940f3f6e46ad227d00f8dc2a5d2be243e7222615
diff --git a/dev-python/mpmath/mpmath-1.3.0-r1.ebuild b/dev-python/mpmath/mpmath-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..d6d7fdab14b5
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.3.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi virtualx
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="
+ https://mpmath.org/
+ https://github.com/mpmath/mpmath/
+ https://pypi.org/project/mpmath/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" mpmath/tests/runtests.py -local || die "Tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "gmp support" dev-python/gmpy
+ optfeature "matplotlib support" dev-python/matplotlib
+}