summaryrefslogtreecommitdiff
path: root/dev-python/moviepy/moviepy-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/moviepy/moviepy-1.0.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/moviepy/moviepy-1.0.1.ebuild')
-rw-r--r--dev-python/moviepy/moviepy-1.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/moviepy/moviepy-1.0.1.ebuild b/dev-python/moviepy/moviepy-1.0.1.ebuild
new file mode 100644
index 000000000000..41b2da26b5c7
--- /dev/null
+++ b/dev-python/moviepy/moviepy-1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Video editing with Python"
+HOMEPAGE="http://zulko.github.io/moviepy/"
+SRC_URI="https://github.com/Zulko/moviepy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/imageio[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ virtual/ffmpeg
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest