summaryrefslogtreecommitdiff
path: root/dev-python/moto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-17 13:54:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-17 13:54:39 +0100
commitfe7238eca1d510cb096bf290978af72ba6607930 (patch)
tree564be9d3b7f3c9537d08b9b6a75fb119777c36f3 /dev-python/moto
parent403387a1bc2a2d98e75bf1474b21ae379b88aab2 (diff)
gentoo auto-resync : 17:10:2022 - 13:54:39
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-4.0.7-r1.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 8385fcbcda92..276c75bf42d7 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -3,5 +3,6 @@ DIST moto-4.0.6.tar.gz 2465655 BLAKE2B e9ab47e910baf2b704c87a0d4583bdf02f2e4a1a2
DIST moto-4.0.7.tar.gz 2478859 BLAKE2B ba3df603fd1ea9e944037bc8abe3d9343fab483efe4446045cf81e16d9918e5291e4470e2b6d51faa99c64a581c2a7890eb9a558fd9b4e431b70b5c71393d2a2 SHA512 b0119cfa480d735ac255125c058c1026e0b32690fcedf64889845452bfc9e92dd2f64e3c413bdce24dd43a205b88a9df03896afe96149146a8690b7d6bb4437f
EBUILD moto-4.0.0.ebuild 4096 BLAKE2B 60d3dbe15f9c40b8cfa64fdccd57d1d24152a152449c24e0f5e5bd967471c0e1a181ef3d921ef04c299b2ea9dc13fddfe76c861b0f56f2522e64975850eac786 SHA512 a19ca0cf5b9b0db8a36705a39d84e8a67cc4e9153be8b4f5157736039457803ba51dbebbeca84c24e200c70584905118abce400c8211709bc08ae7e902bef432
EBUILD moto-4.0.6.ebuild 4098 BLAKE2B 524e4925bec974fa3e5c31cfaadbdd7acb0f3638bf4198c48dba3e48f0f8d1185ba4652de7b1f24957ab1a57f61ce3e533af51ee3091b2652fec9ece03a8bf44 SHA512 c28daf0e0919d4b0bdf353d10275385ddd2e3bcf98bf241a33973d31010856b2a2a1437fccdf2cb70381ce8cc4412650b415feb37cdb4d28b6f0cbc8e32e8b8d
+EBUILD moto-4.0.7-r1.ebuild 4170 BLAKE2B 40f9e16c72e4d0e9f85f77a638010028bf8037ac5b35d936860a02b12975088991bfbe46a5ced21416001765594669e688c8d43fe5a1c1c146d2b34b82b8e774 SHA512 0e4a3523bd9c58bf304b847a31b637f53de466850e921513ca70eb2772fa26abf1132db4ff5b88c7fc557c9947dda3e54cb2d5d58a9d96678ec5860809641bc8
EBUILD moto-4.0.7.ebuild 4098 BLAKE2B 524e4925bec974fa3e5c31cfaadbdd7acb0f3638bf4198c48dba3e48f0f8d1185ba4652de7b1f24957ab1a57f61ce3e533af51ee3091b2652fec9ece03a8bf44 SHA512 c28daf0e0919d4b0bdf353d10275385ddd2e3bcf98bf241a33973d31010856b2a2a1437fccdf2cb70381ce8cc4412650b415feb37cdb4d28b6f0cbc8e32e8b8d
MISC metadata.xml 552 BLAKE2B c0162cc80007c1fda211c105b3e7391e3596ef11deb9257bab489f4b112f79ed115ca3f250bdf1b87aee0af258aa59056c8d062acebca7dec631acf3ec9eb2bb SHA512 3f7b3c5709bca51588e58f9eeb9bb363e2657a7e6483519ec7782eb047a5311d434e2459ccd3b495340f85f72a92da2f7cc6eb3de617e979bade7b8fc7b3c01d
diff --git a/dev-python/moto/moto-4.0.7-r1.ebuild b/dev-python/moto/moto-4.0.7-r1.ebuild
new file mode 100644
index 000000000000..6249184fce6a
--- /dev/null
+++ b/dev-python/moto/moto-4.0.7-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ tests/test_appsync/test_server.py::test_appsync_list_tags_for_resource
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_s3/test_server.py::test_s3_server_post_to_bucket_redirect
+ tests/test_s3/test_multiple_accounts_server.py::TestAccountIdResolution::test_with_custom_request_header
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}