summaryrefslogtreecommitdiff
path: root/dev-python/moto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-12 11:41:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-12 11:41:02 +0100
commitd15be4fe2ff3e70717117a938dbe5a11cec60a7b (patch)
tree11b55e9435c5d885c195338bb42507d74636c34c /dev-python/moto
parent81663ab80e0e0c5839b216934509b6bcbf08429a (diff)
gentoo auto-resync : 12:04:2023 - 11:41:02
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest2
-rw-r--r--dev-python/moto/moto-4.1.7.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index edb534ea4ef4..91923c87ee48 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,3 +1,5 @@
DIST moto-4.1.6.tar.gz 3470215 BLAKE2B 78f9c54128ba71fc5e3ba622be0596490bc82df0a17fa80d9f11bf135bdc91d9698cc29445b5765e6057e80f221c016ca8999186201b83b5f929f5831c417f60 SHA512 fb2dc73a66326216a4c5338660dab844de9a46e6626e0ef68bccb3573a3eba693b30b89961b019a4b7a51207ab11335e73cbdf523c75d91a5a9625a1bc409e61
+DIST moto-4.1.7.tar.gz 3506753 BLAKE2B 76e38629f1a772816bfa647b90e89e3c4533cd36fa5a8a26e026229dd1dd8bf1cea404f99c85784a6eefa9173aecff7b88ba1ca7b3f890407c2ad7ef29106fac SHA512 3b20d2a535654cee22c909e19eb492e3b4b8fd382d26367c12cee00128dc4d1ea5228ccc97d40a01c5c2707ff3ca1039644268c47c525c79a9b68fc7ee78541c
EBUILD moto-4.1.6.ebuild 4672 BLAKE2B d687a54839c5912b281612bb50477fbe6daca0b7c5f19f2eb9a59f2c52f513724e33f459fb06171a1ec5c11a02b5fbd62edab1624514b54781f2886b494aab55 SHA512 ae631cf4e0bead498ccac991c06feba779207728b46af73d3f680350e77c9c534865fa5c0c0db1e31d2f47bfaf34e3c30b95d5e69142ba329c47913163797d42
+EBUILD moto-4.1.7.ebuild 4674 BLAKE2B 5287db1684a2acc0a182ffbc40b6aec8800b6f4e505891b0df30c0a88141155e08dc5ad8b5934f634c6c830479e30e6decb2bbca2d50bf5a455da4623c9b29f2 SHA512 92addae1b34a8968501523ee1bd2b656b4fe55e5d54a6a1e2056d3e8db4b1c8836ed55d66ee992218e6b4f3244d480bad88e874232b05b16e310d236688b69a1
MISC metadata.xml 553 BLAKE2B 1669d17d3e655aa3fb41a489229a5fbfa6a9cfb23c667e98fbbef931992c7e9645581b9ea12011601093586cba491a5557d68e5256edb9f387c4db362346edf9 SHA512 48ae3bd9be8c3bfb68f7022d0e7bb422c2a06157967809be302067facf91db825023859d18ccea89109931538b0e93181d54a31fcc967628df61a9a3112edd3d
diff --git a/dev-python/moto/moto-4.1.7.ebuild b/dev-python/moto/moto-4.1.7.ebuild
new file mode 100644
index 000000000000..d30e9392b520
--- /dev/null
+++ b/dev-python/moto/moto-4.1.7.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/getmoto/moto/
+ https://pypi.org/project/moto/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ tests/test_appsync/test_server.py::test_appsync_list_tags_for_resource
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_core/test_docker.py::test_docker_is_running_and_available
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_s3/test_server.py::test_s3_server_post_to_bucket_redirect
+ tests/test_s3/test_multiple_accounts_server.py::TestAccountIdResolution::test_with_custom_request_header
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ # TODO
+ tests/test_batch/test_batch_jobs.py::test_failed_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_job
+ tests/test_batch_simple/test_batch_jobs.py::test_submit_job_by_name
+ tests/test_core/test_environ_patching.py::test_aws_keys_can_be_none
+ tests/test_core/test_mock_all.py::test_context_manager
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_queue
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_fifo_queue
+ # require py_partiql_parser
+ tests/test_s3/test_s3_select.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}