summaryrefslogtreecommitdiff
path: root/dev-python/moto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-06 11:42:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-06 11:42:16 +0000
commita03b2fe2d845ae950995bf1c5255da420cbd92d2 (patch)
tree7c05b96187cce0c598ea9af9fe03ab294f4df6e5 /dev-python/moto
parent9e0addc1cf71ebec277b59e38eb3fa30e650cf9f (diff)
gentoo auto-resync : 06:02:2024 - 11:42:15
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest2
-rw-r--r--dev-python/moto/moto-5.0.1.ebuild9
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 168f2588e7e6..f3e2d7b51e47 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -20,5 +20,5 @@ EBUILD moto-4.2.7.ebuild 5602 BLAKE2B 652d910f9dcf9f2de0974aa1c3e9ff25487b4693aa
EBUILD moto-4.2.8.ebuild 5490 BLAKE2B 7b20396b028362a9d3574c3195da23b0db482e85c02a858c843863f07f035650df03be200a42c91e4b960a2abaeb7e4eaa3b0b5ce24261378b14d5db3374ccbf SHA512 6826bc9b420815f5e5922d1cf83ff44ec9fdb9365d75999dc3e371f30c64b433c116e4b0221c17c417a7a6c8162ebd714d5fc708226a87f205322c2280baafd1
EBUILD moto-4.2.9.ebuild 5686 BLAKE2B 04cc2c9889141fb1d54ed028e4046672901c7f1aeaa86a46798a54c0ea2372458ade16ac93d2d9fa74fd8b67555902c60f1b00e1557922d4ac370e43b4648073 SHA512 e7f0246caa5cb751a6b26c55c1309dbe17a1689e89924a0a3f5979262ddb6bb007d801f8ae3a5cc2893287240b430a2a7df90efc592e94baf8c20d5266e612d0
EBUILD moto-5.0.0.ebuild 6626 BLAKE2B 957d9c398c87f73a83afd9feb358b6ce2965a7d046c84f98ab60bd1203a934cea160571c693d86c196d48944a970e70a8212e4434a4ab509bad34892f2fd602c SHA512 434aab010656345047b7c793be213b581fab6529f34b073d387518a5ab3e58bafe38b10bf4dd117d737701c0131126bd94f0fe1f8bbf6fb207172a5f2edf129c
-EBUILD moto-5.0.1.ebuild 6626 BLAKE2B 957d9c398c87f73a83afd9feb358b6ce2965a7d046c84f98ab60bd1203a934cea160571c693d86c196d48944a970e70a8212e4434a4ab509bad34892f2fd602c SHA512 434aab010656345047b7c793be213b581fab6529f34b073d387518a5ab3e58bafe38b10bf4dd117d737701c0131126bd94f0fe1f8bbf6fb207172a5f2edf129c
+EBUILD moto-5.0.1.ebuild 7067 BLAKE2B ff2b57009c69420058a4e1854cc68b24e2ef0b393d2b2fd8952a71dc6e5d4595015746aaffa44a46dfc667c10ee32df4b65f05dd7de1b34436265bfd4a5a2614 SHA512 1ac9e24bcc8f8b9a46b947026c4e1228be5864022a64563113b2bd96ce76eafd7612e5e3bf241c65b17664556eba65c0707c58b842525ca0f03eabda170fd1f3
MISC metadata.xml 553 BLAKE2B 1669d17d3e655aa3fb41a489229a5fbfa6a9cfb23c667e98fbbef931992c7e9645581b9ea12011601093586cba491a5557d68e5256edb9f387c4db362346edf9 SHA512 48ae3bd9be8c3bfb68f7022d0e7bb422c2a06157967809be302067facf91db825023859d18ccea89109931538b0e93181d54a31fcc967628df61a9a3112edd3d
diff --git a/dev-python/moto/moto-5.0.1.ebuild b/dev-python/moto/moto-5.0.1.ebuild
index 821d9d148f5d..9c9b637a38ee 100644
--- a/dev-python/moto/moto-5.0.1.ebuild
+++ b/dev-python/moto/moto-5.0.1.ebuild
@@ -96,10 +96,15 @@ python_test() {
# broken by new urllib3
tests/test_moto_api/recorder/test_recorder.py::TestRecorder::test_s3_upload_data
tests/test_moto_api/recorder/test_recorder.py::TestRecorder::test_s3_upload_file_using_requests
- tests/test_s3/test_s3.py::test_upload_from_file_to_presigned_url
- tests/test_s3/test_s3.py::test_put_chunked_with_v4_signature_in_body
+ tests/test_moto_api/recorder/test_recorder.py::TestThreadedMotoServer::test_server
tests/test_s3/test_s3.py::test_presigned_put_url_with_approved_headers
tests/test_s3/test_s3.py::test_presigned_put_url_with_custom_headers
+ tests/test_s3/test_s3.py::test_put_chunked_with_v4_signature_in_body
+ tests/test_s3/test_s3.py::test_upload_from_file_to_presigned_url
+ tests/test_s3/test_s3_bucket_policy.py::TestBucketPolicy::test_block_all_actions
+ tests/test_s3/test_s3_bucket_policy.py::TestBucketPolicy::test_block_all_with_different_principal
+ tests/test_s3/test_s3_bucket_policy.py::TestBucketPolicy::test_block_or_allow_get_object
+ tests/test_s3/test_s3_bucket_policy.py::TestBucketPolicy::test_block_put_object
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1