summaryrefslogtreecommitdiff
path: root/dev-python/moto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-12 12:25:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-12 12:25:39 +0100
commit37bccfe5e76c5740c4ef5ba1179e9488d8404075 (patch)
treec0c962a2e83c1f38816a021ecd34c2e8c80db528 /dev-python/moto
parent496ef6155c315ac3628b472dc9b4146fa2684286 (diff)
gentoo auto-resync : 12:07:2024 - 12:25:38
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest2
-rw-r--r--dev-python/moto/moto-5.0.11.ebuild15
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 7c97ad4d5a1d..34da46f8fe6f 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -4,6 +4,6 @@ DIST moto-5.0.11.tar.gz 5295376 BLAKE2B c2077e020918940ee3642b7b0a8c467df48122e3
DIST moto-5.0.9.tar.gz 5256902 BLAKE2B a817d42f05d8b2fa65585ac5f0404f995bb4b6ca7d70305db0d12cc526745c4af1c36ac2067af33d2b688a7076dff7eb6bdad117c38ac54c873e7149a3e8a1bf SHA512 44ac3a91a759105db5bd48950a7b19d3df9612b41b4062eb7df08bb864e99f982731ae973b24a7c5547c0fd47e07a703c21be7260730983abad46d154c9f7742
EBUILD moto-4.2.14.ebuild 6506 BLAKE2B dca88183bb8c0d935869b2293abf55c4c1687b79faa305fa971cffbd52e987cd0eee4ab92b837125625898b6c083a88a682cfe04a3438536268bac87ac659a0e SHA512 aa0e668f2566e657a19d22c4fff4ef213b47837ed9b2a833eb6594c5b6261230ee675151a0c6d4f8d13764b028c0f3f55094b30cc33f025df3bf8ecb1d719105
EBUILD moto-5.0.10.ebuild 8249 BLAKE2B fe5e648702888ed5e2195b4ecd0a313e39af8e68eecdae6ed37dabd633383045d61256de800877cc56df1e8aec71eb798eb1432e779be15eefcfde9a7c787173 SHA512 890a6ee6d0b628e32967ed9320e88504453557eb39fbc0e51930bd129730b5a825e828d4af4e92a485e688789d2f33f35ec895577951a5174cfd0a5d33a7d805
-EBUILD moto-5.0.11.ebuild 8249 BLAKE2B fe5e648702888ed5e2195b4ecd0a313e39af8e68eecdae6ed37dabd633383045d61256de800877cc56df1e8aec71eb798eb1432e779be15eefcfde9a7c787173 SHA512 890a6ee6d0b628e32967ed9320e88504453557eb39fbc0e51930bd129730b5a825e828d4af4e92a485e688789d2f33f35ec895577951a5174cfd0a5d33a7d805
+EBUILD moto-5.0.11.ebuild 8750 BLAKE2B ed384742f0c01437985a0a3c8ca5e9610f95722ded0043e3d242113aeceb39084a2bf3a14c3a5ee3f4a5683bbc5da3b4e9d15c8d963b51d1759db5aa49ac7243 SHA512 3a2cd57307d91ae78f618c052154f0cce835a552610110cd5f08c75fe9725610512271c244ab0d879158a445434a6e7bc8469ab326c36dbb19dca5a09aa3d41a
EBUILD moto-5.0.9.ebuild 8246 BLAKE2B 8cb3a3fe8b2651a0bbb43f8f308e6dad95f67fc0e09cd52d6596ad7a5fbea67de6743da532db07c9e65a1b5ed9e913666a8af9363a1792b3201c18bf78d1aed6 SHA512 fc759eb0b0999d3e9308ff572ae5c4982a8d1e70a5ee242ebaf9628af3719d90de5f30a1e33ab6281aebbdce7f1c6e1dba3a05879990a0fda07ae5bf84193a54
MISC metadata.xml 553 BLAKE2B 1669d17d3e655aa3fb41a489229a5fbfa6a9cfb23c667e98fbbef931992c7e9645581b9ea12011601093586cba491a5557d68e5256edb9f387c4db362346edf9 SHA512 48ae3bd9be8c3bfb68f7022d0e7bb422c2a06157967809be302067facf91db825023859d18ccea89109931538b0e93181d54a31fcc967628df61a9a3112edd3d
diff --git a/dev-python/moto/moto-5.0.11.ebuild b/dev-python/moto/moto-5.0.11.ebuild
index e033c5815571..567ad8433789 100644
--- a/dev-python/moto/moto-5.0.11.ebuild
+++ b/dev-python/moto/moto-5.0.11.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi toolchain-funcs
@@ -180,5 +180,18 @@ python_test() {
"${EPYTEST_DESELECT[@]}"
"${serial_tests[@]}"
)
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ tests/test_ses/test_ses_boto3.py::test_send_raw_email
+ tests/test_ses/test_ses_boto3.py::test_send_raw_email_validate_domain
+ tests/test_ses/test_ses_boto3.py::test_send_raw_email_without_source
+ tests/test_sesv2/test_sesv2.py::test_send_raw_email
+ tests/test_sesv2/test_sesv2.py::test_send_raw_email__with_specific_message
+ tests/test_sesv2/test_sesv2.py::test_send_raw_email__with_to_address_display_name
+ )
+ ;;
+ esac
+
epytest -m 'not network'
}