summaryrefslogtreecommitdiff
path: root/dev-python/moto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-21 20:41:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-21 20:41:46 +0100
commit2518522472e5de9c52c78dc0246475fe0ae3cc05 (patch)
tree75e45cd85194021231c22ad696e2900ab56b8f15 /dev-python/moto
parentcb701a27e552fb85d830f305bee3e17cddae0234 (diff)
gentoo auto-resync : 21:08:2022 - 20:41:46
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest2
-rw-r--r--dev-python/moto/moto-4.0.0.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index d88075f695c7..a2a2c9398698 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,5 +1,7 @@
DIST moto-3.1.16.tar.gz 2318840 BLAKE2B 775c952c7c5df36a859bfbb4417d613207f51643c129f37fd88398c9185109ee99be948db234573f02fd301a1541c1d50dde0d5fe296561f3382320fc671beec SHA512 c893b6de5bc5bf7bc025e320825d388de878affc83d1b54457f898891d306ce0c8dcb4aecfc33119cd2df78e5a9b0d07031cc45db4d965c0cab0bcb6154b0d34
DIST moto-3.1.17.tar.gz 2353251 BLAKE2B 9ea4b0eb7cd4598e9af967451b2193e80864171eb670c24c36178be49f295cca0aa4bbdb6c1d3c5b7ef1e88eea859a0e512e196044c3b141c08fbe85098c172a SHA512 fcc7975c27c0b93933c2d56427d2b49c65f4dc8281c2f573e82fda7709d6202fc02e0c89312db4d40f3b17a55ba6a998da11b42074a9dfb2ceebfbdf812b184f
+DIST moto-4.0.0.tar.gz 2404959 BLAKE2B a9969cb306937deaa15aca1ee76a447d0e416a7be160da9c81ce30e5147fd595cbe7b38f84ee26e795d055e3f62a6c1467e176d9b7ee58197c9d22a34f94918e SHA512 11bc093b6e89bad5340433daee0f9ba482a8534ab73a57a77556510f1dfef8186ee45b6c914bab291e861eb50d4bda7686d3d22d469db87a79e3247dbefd2e6d
EBUILD moto-3.1.16.ebuild 3952 BLAKE2B c973165d7405a0ae7574cabe74b162e802e8b73ffb47777f6f815bb27f6c6677c56a1ac20166e99382854549798c55db798a6bcb3484e534f58a068c2ecc2f22 SHA512 9edfbfd062bae8d80a36eea36f53f9b255c370e5b34bcc3649a8bdc25efa32fe1aad8ac0be91a99ced0f6142825146a7a7b63455457a8bebeb1a9f36019248d5
EBUILD moto-3.1.17.ebuild 3954 BLAKE2B 75a068f77e5a8328fca12cc29ef15d02b3fe2371fb15862e7f2385d4094caff3a7c1a84fbc3fce0c31899aa53df14a23be8f92c5a2a0973d4377f5ca6708fa98 SHA512 b1fd624f48745859c4b867d7548a40e10039c8e78e262c2fb528eb72c4ff42b35de276cbed81e461f4d820710db5dc0e7af4e14b4a7793dc7adfc4dd26fe6e8b
+EBUILD moto-4.0.0.ebuild 4098 BLAKE2B 524e4925bec974fa3e5c31cfaadbdd7acb0f3638bf4198c48dba3e48f0f8d1185ba4652de7b1f24957ab1a57f61ce3e533af51ee3091b2652fec9ece03a8bf44 SHA512 c28daf0e0919d4b0bdf353d10275385ddd2e3bcf98bf241a33973d31010856b2a2a1437fccdf2cb70381ce8cc4412650b415feb37cdb4d28b6f0cbc8e32e8b8d
MISC metadata.xml 552 BLAKE2B c0162cc80007c1fda211c105b3e7391e3596ef11deb9257bab489f4b112f79ed115ca3f250bdf1b87aee0af258aa59056c8d062acebca7dec631acf3ec9eb2bb SHA512 3f7b3c5709bca51588e58f9eeb9bb363e2657a7e6483519ec7782eb047a5311d434e2459ccd3b495340f85f72a92da2f7cc6eb3de617e979bade7b8fc7b3c01d
diff --git a/dev-python/moto/moto-4.0.0.ebuild b/dev-python/moto/moto-4.0.0.ebuild
new file mode 100644
index 000000000000..deb2ce6bae60
--- /dev/null
+++ b/dev-python/moto/moto-4.0.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ tests/test_appsync/test_server.py::test_appsync_list_tags_for_resource
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_s3/test_server.py::test_s3_server_post_to_bucket_redirect
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}