summaryrefslogtreecommitdiff
path: root/dev-python/moddb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-19 03:03:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-19 03:03:00 +0000
commitf2e359c456b051f95efc92e21299d55a302e58ed (patch)
tree9d844c8fa1373b6f4244c1cfbe55eea7cdf62701 /dev-python/moddb
parentf9f6fa91738181ebe9aca71b75d157d8b5df5335 (diff)
gentoo auto-resync : 19:11:2024 - 03:03:00
Diffstat (limited to 'dev-python/moddb')
-rw-r--r--dev-python/moddb/Manifest2
-rw-r--r--dev-python/moddb/moddb-0.12.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/moddb/Manifest b/dev-python/moddb/Manifest
index 578ea443e40b..51f39c827283 100644
--- a/dev-python/moddb/Manifest
+++ b/dev-python/moddb/Manifest
@@ -1,3 +1,5 @@
DIST moddb-0.11.0.gh.tar.gz 10528613 BLAKE2B 109c1758362e2655209173d581f1234f15725b8d0b25ed8024ecdfc4da45e30530c87fa9b8a19b556f4cfa60549c38bc552751a39a5dad28f04e58f53d1f484f SHA512 fe064fb7b02553d614477f122013c98257c6fd4d428538681ea97706425480d7fb4a25f49b8673dfba706e33766420c930cee1fae0c93a6b3d2f766b609596ca
+DIST moddb-0.12.0.gh.tar.gz 10528424 BLAKE2B 48a41ee5d150afffbde459bc44c0edb2056cb3674966193a595bc2d6c467746029e3741e9a107edfee3177a5135f2fd5ea040e8d15e1ab88f9c0d0c9bd2cb9f2 SHA512 2c31724093bfcb45c95cf29ae5ad430f77c0061a7d3588688a755101b50a79034c5bf633df5d9a032fa21deb5a8aab12d491289b6937ce1011fe67860c5c769c
EBUILD moddb-0.11.0.ebuild 1378 BLAKE2B 22bd7fb6226003d9484a0877f8ac675bc7db196b76d015918834526c03cbf1bb8b6f85dfdf4768e75fc41ec549352fbcb7273655d27560102f3fc893ea465bd4 SHA512 4abdd687147e1bef6abdaa2643616a9d3448aaa4cd3c437f34e765b8dc2f0e60b0ef340ad1208e32c03267f3a02403811c81a50ac7556753e52b8130d26152e3
+EBUILD moddb-0.12.0.ebuild 1388 BLAKE2B cf07ff907f6de713fee2c2c8fee75ec73220e0da16a2f39cf02147c2e3b92dc5953ee3f3664b372967f990098123e726a87c83e0ae6c921b7a85a95eacb77e4c SHA512 ce55caa661d22e5e9f14be819fd15269e215314ed87d2b2fa00e4c38fc05d716192e2b095e53a1b8fd3cb405dff78a14a2d9df597e4bfae6ac4840090a2b77fd
MISC metadata.xml 394 BLAKE2B d3dfb13cd925f28939a618f48767bb10c1790f28eab0551dbcd00b6fbb8c01959ee26f9f6352107954ae3ee4b3df16f30ceb20ad3b357fc45ea2286b0a6c2c16 SHA512 5943dcbfab94ed9cd84ab275d7e4bf5281c0e3f6ae1d2efe868a68570b240a1d4ff36687f693c00e46a5e8e6fa41691b07d751a04dcaeff24eda484f0be302c0
diff --git a/dev-python/moddb/moddb-0.12.0.ebuild b/dev-python/moddb/moddb-0.12.0.ebuild
new file mode 100644
index 000000000000..3fd529c4f0f4
--- /dev/null
+++ b/dev-python/moddb/moddb-0.12.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scrapper to access ModDB mods, games and more as objects"
+HOMEPAGE="https://github.com/ClementJ18/moddb"
+SRC_URI="https://github.com/ClementJ18/moddb/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Connects to moddb.com
+RESTRICT="test"
+PROPERTIES="test? ( test_network )"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+)"
+
+EPYTEST_DESELECT=(
+ # These tests require valid moddb.com login information
+ "tests/test_base.py::TestLogin::test_login"
+ "tests/test_client.py::TestClient::test_get_watched"
+ "tests/test_client.py::TestClient::test_get_updates"
+ "tests/test_client.py::TestClient::test_posts"
+ "tests/test_client.py::TestClient::test_friends"
+ "tests/test_client.py::TestClient::test_messages"
+)
+
+distutils_enable_sphinx docs/source dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+python_test() {
+ # Dummy moddb.com login information
+ export USERNAME="portage"
+ export SENDER_USERNAME="portage"
+ export PASSWORD="testing"
+ export SENDER_PASSWORD="testing"
+ epytest
+}