summaryrefslogtreecommitdiff
path: root/dev-python/moddb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
commit3e42d1577189af123b773dc0f11e5419035308c8 (patch)
tree95d77507c924544b12363e6da6aa741c444f3e8a /dev-python/moddb
parent6243676c91946098c06d42bc87b5eb99aac40bf0 (diff)
gentoo auto-resync : 26:04:2024 - 23:59:36
Diffstat (limited to 'dev-python/moddb')
-rw-r--r--dev-python/moddb/Manifest2
-rw-r--r--dev-python/moddb/moddb-0.11.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/moddb/Manifest b/dev-python/moddb/Manifest
index e1c3056e5df6..2872f608bcd6 100644
--- a/dev-python/moddb/Manifest
+++ b/dev-python/moddb/Manifest
@@ -1,3 +1,5 @@
DIST moddb-0.10.0.gh.tar.gz 14174575 BLAKE2B cffcdb27d3bd43da412d9ce689ba06d59ee013d4b78b75fddc8749243aaa6abb50c576811ef8e8e88c66ff41b578a79daec4ce0dbe56f444c94eeabedb0fef89 SHA512 5b21aea8a76c2b28579dbb3587956042126b65248684c2c6caef43793b8e7dd1d318434783c252ef191ee7832ea9fe1a434797797a9a76804133a53ede7674f9
+DIST moddb-0.11.0.gh.tar.gz 10528613 BLAKE2B 109c1758362e2655209173d581f1234f15725b8d0b25ed8024ecdfc4da45e30530c87fa9b8a19b556f4cfa60549c38bc552751a39a5dad28f04e58f53d1f484f SHA512 fe064fb7b02553d614477f122013c98257c6fd4d428538681ea97706425480d7fb4a25f49b8673dfba706e33766420c930cee1fae0c93a6b3d2f766b609596ca
EBUILD moddb-0.10.0.ebuild 1464 BLAKE2B 703668ab2f410347f284f3e7d489c57ad288433f4f78e16f45d0e8a21a9fe361052d2ac6db6e20e25ea6b2ccf80b12133a5b9ee784dafcb548b530ab8438e881 SHA512 9e3ea8edb69ead715531e89d595f0a72a79aaf821dc78b24ff8d61842cc1477e403eb4d05e0ea3cbbaa781c34d083b027e45190cf250be2200a7a2b09b02aad5
+EBUILD moddb-0.11.0.ebuild 1378 BLAKE2B d4f0ee956439bd752fc26d5f3f874b0f2371f46dbb0bc02ecacc12006e65e5ba92e4d4ca7dfefd2cb0293ad14681fb6b6813fd9e973e53d61bc751b26c967b6a SHA512 b9d6627262c9eb3ef7cd51d7f9752e0fdfcdd1568a49969be46f640ee4cebdf32ed3c0fa73e87f1497b7e8620042130665b90c26f0ae291cbb7e45a00b3e1315
MISC metadata.xml 407 BLAKE2B c1651872c2ae76f7adf6fd307c7b7b3c4ff5c9b7a193d58651648de31c63f9c24e35c178ac4fbed18c2bdd247cf2fd247e1a579a1dea92747f5545f155ef5595 SHA512 e24bb351e9a98d5c86694447a9c4007df28de831f4a570e998316d81688347f038cd802441f89ab9cdcc7b4ab7079096ca3c8ff590ac7bf5453e442186304d5d
diff --git a/dev-python/moddb/moddb-0.11.0.ebuild b/dev-python/moddb/moddb-0.11.0.ebuild
new file mode 100644
index 000000000000..ce605c46602e
--- /dev/null
+++ b/dev-python/moddb/moddb-0.11.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scrapper to access ModDB mods, games and more as objects"
+HOMEPAGE="https://github.com/ClementJ18/moddb"
+SRC_URI="https://github.com/ClementJ18/moddb/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Connects to moddb.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+)"
+
+EPYTEST_DESELECT=(
+ # These tests require valid moddb.com login information
+ "tests/test_base.py::TestLogin::test_login"
+ "tests/test_client.py::TestClient::test_get_watched"
+ "tests/test_client.py::TestClient::test_get_updates"
+ "tests/test_client.py::TestClient::test_posts"
+ "tests/test_client.py::TestClient::test_friends"
+ "tests/test_client.py::TestClient::test_messages"
+)
+
+distutils_enable_sphinx docs/source dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+python_test() {
+ # Dummy moddb.com login information
+ export USERNAME="portage"
+ export SENDER_USERNAME="portage"
+ export PASSWORD="testing"
+ export SENDER_PASSWORD="testing"
+ epytest
+}