summaryrefslogtreecommitdiff
path: root/dev-python/mmtf-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/mmtf-python
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/mmtf-python')
-rw-r--r--dev-python/mmtf-python/Manifest3
-rw-r--r--dev-python/mmtf-python/metadata.xml15
-rw-r--r--dev-python/mmtf-python/mmtf-python-1.1.2.ebuild19
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/mmtf-python/Manifest b/dev-python/mmtf-python/Manifest
new file mode 100644
index 000000000000..423ffaae17dc
--- /dev/null
+++ b/dev-python/mmtf-python/Manifest
@@ -0,0 +1,3 @@
+DIST mmtf-python-1.1.2.tar.gz 46309 BLAKE2B b21d53f7cfbdf6f6bd4f0f3ac31a846e83ce0ee98faf77fa8d06de7520c4aa64a259e8b43a744a440a6cf1a10ad461697334683364698a68222b690301bc5554 SHA512 92afcce48c2de186cbf9c2cb39c94c5df14ae0eb613862d41b674b7d2f338855ed81be23fb14d16d2dfc8d33415d3904537ef4a422e3a52b78d461b609e968ca
+EBUILD mmtf-python-1.1.2.ebuild 455 BLAKE2B 6a598e555c23b64ec0e185c524f806f05806157cc215e1bfd2f63ba9cd719186a8322405c8ce9c3e5a2717ce6927caafc17f85d12d52471e48c77e1bb7a230b2 SHA512 ab14cf869a207b8f623650f6195d13d1d53f8eae1424c9a4bb57c01956c9e546c2a0e7279df34d9c4bb5e0f206133b762d366a895b4f4366d048d5a4e3e713a1
+MISC metadata.xml 430 BLAKE2B a69050101da1e1dccf6b335506250cfaac02f1b87c87946d72aa1c3649c2f5ca107c4772b9dc410088397be824c59b2c9e6e611ba548b7b007aa22e7d9a12a46 SHA512 1245d1c1479afc4dde1a787d65342997754715a530a81d73fac1512a5d20e54fb36c80c1be1fe017b1ff9c14ee786f3b0da6b1a7bf689619285c7a86d5d376b5
diff --git a/dev-python/mmtf-python/metadata.xml b/dev-python/mmtf-python/metadata.xml
new file mode 100644
index 000000000000..e4904232b6f2
--- /dev/null
+++ b/dev-python/mmtf-python/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rcsb/mmtf-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mmtf-python/mmtf-python-1.1.2.ebuild b/dev-python/mmtf-python/mmtf-python-1.1.2.ebuild
new file mode 100644
index 000000000000..ed4888bc9a11
--- /dev/null
+++ b/dev-python/mmtf-python/mmtf-python-1.1.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="The python implementation of the MMTF API, decoder and encoder"
+HOMEPAGE="http://mmtf.rcsb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]"