summaryrefslogtreecommitdiff
path: root/dev-python/mmtf-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/mmtf-python
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/mmtf-python')
-rw-r--r--dev-python/mmtf-python/Manifest2
-rw-r--r--dev-python/mmtf-python/mmtf-python-1.1.3.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/mmtf-python/Manifest b/dev-python/mmtf-python/Manifest
index c080e0eea8bc..8f2d665d6cb8 100644
--- a/dev-python/mmtf-python/Manifest
+++ b/dev-python/mmtf-python/Manifest
@@ -1,3 +1,5 @@
DIST mmtf-python-1.1.2.tar.gz 46309 BLAKE2B b21d53f7cfbdf6f6bd4f0f3ac31a846e83ce0ee98faf77fa8d06de7520c4aa64a259e8b43a744a440a6cf1a10ad461697334683364698a68222b690301bc5554 SHA512 92afcce48c2de186cbf9c2cb39c94c5df14ae0eb613862d41b674b7d2f338855ed81be23fb14d16d2dfc8d33415d3904537ef4a422e3a52b78d461b609e968ca
+DIST mmtf-python-1.1.3.tar.gz 46032 BLAKE2B a19d7e02b08bf7e4d0c820aa2fd06e0f01a10f807efcc0ebed8c2841dc82b0c27ff690934f941d360086217801c3722060a18805dc4144655b0707cc759b93e2 SHA512 44558ea3e38e8eb6431e597253473e49d4a4e3835f790f375f923d3c3702b3c096d5ecaac090a8fabc1cd285d6cfa8dbd3f7d6186d765b92d718ca6d34ad063b
EBUILD mmtf-python-1.1.2-r1.ebuild 645 BLAKE2B d27592548b28d84bc84fd529ef685c817dc7e93ec09b621747cb022a41fc9530ce969b17880627e8e08e2dcc86bfc14b8eba72a63ce9060907e885cc3b14a027 SHA512 17f96f4537e13a53395b97be0270ab8388d0901da8d45daa83e61577c521cb0e698580f5be1fd917a926aa01a5bda71f45619a053ee0fdeaffa038fb9b2b8c01
+EBUILD mmtf-python-1.1.3.ebuild 681 BLAKE2B b7e14700776bbecf196d642ca7f4140c98057419c836f3a5b7f7a7873519588ba21b010c1445b4cf4af131a7db2d59f9b042f188aafccfee2ee3476565804f23 SHA512 837567bdb2764f1c58471d381e476cfc97da5ed7921d8d8896d6ce8f2de3f2496c5583ae1cd0b6ff7faf73f2ac13e696444237dfd65253dcce34c8c65cd57545
MISC metadata.xml 379 BLAKE2B 90b38a443c63992c8b0fc156013465ac50477ab361e5f2b09c25fd74d1440dc6380a917a27818aa5cb226224caee262dcee550ff658dd2273b546dcad5ef883a SHA512 a8b5f4777dfa84dd55cdba1195ccaecfa8063582d5b4759bfd6281b63769b22d80b214e508f0cdd0c54e8f8f011ed71195943fedfd668c39ad3e99084098d796
diff --git a/dev-python/mmtf-python/mmtf-python-1.1.3.ebuild b/dev-python/mmtf-python/mmtf-python-1.1.3.ebuild
new file mode 100644
index 000000000000..ac234e7f5a34
--- /dev/null
+++ b/dev-python/mmtf-python/mmtf-python-1.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="The python implementation of the MMTF API, decoder and encoder"
+HOMEPAGE="http://mmtf.rcsb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" mmtf/tests/codec_tests.py -v || die "Tests failed with ${EPYTHON}"
+}