summaryrefslogtreecommitdiff
path: root/dev-python/ml-dtypes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-04 23:42:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-04 23:42:56 +0000
commit7b43cd44c0c26cd9e0ae1dcd94596667cb119ee6 (patch)
tree9715703a1ec2185bfa303bd2d2b04e560654f72a /dev-python/ml-dtypes
parent27ad6a285576ce16e4c74d806efee77166f0c3c6 (diff)
gentoo auto-resync : 04:02:2024 - 23:42:56
Diffstat (limited to 'dev-python/ml-dtypes')
-rw-r--r--dev-python/ml-dtypes/Manifest6
-rw-r--r--dev-python/ml-dtypes/metadata.xml12
-rw-r--r--dev-python/ml-dtypes/ml-dtypes-0.2.0.ebuild36
-rw-r--r--dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild36
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/ml-dtypes/Manifest b/dev-python/ml-dtypes/Manifest
new file mode 100644
index 000000000000..d1aba811fb8a
--- /dev/null
+++ b/dev-python/ml-dtypes/Manifest
@@ -0,0 +1,6 @@
+DIST eigen-7bf2968fed5f246c0589e1111004cb420fcd7c71.tar.bz2 2239233 BLAKE2B 3a7e81c302cb11ae1d6ef9433a9ec41506c1f37d04cfb8744ac3fcf7dbe9430c1b48d7197ca3b8e1f9354398bac3d0dbc3e0599c0b649acd6175e906befe2973 SHA512 29ee89770726e6e0f5135b7fab24649f3e69223caed90d2daa6f0014783e69fe98f0551de49bd4e393d7b7938f2943caf1ed00f3933fa771ac14fae3c63fd5dd
+DIST ml_dtypes-0.2.0.gh.tar.gz 66155 BLAKE2B fc3bcdc8af99a232611b2b9da3ff640852f236dd6b13b8e3fbb9e47934e8a30f3d4d009b845ec1da6f96a4b2fe04e269cef29a5f44061ed9cd38ba24a7d7ce2e SHA512 5903534832f75c13c4fbd5522ff5d93a2d1bf0cbc0226c72f26c4b8137df74fd6603230e5f6de7a58d68f38ff70d97f9e1f3a256b1b64ef611b3f522cb492682
+DIST ml_dtypes-0.3.2.gh.tar.gz 71606 BLAKE2B cbf5414d09160a2e4e878261c5842efd664a424064aae727d9d1188304a5e888ca955b3bf199956c2beed53c78c0f8afeb8860245d57553b10ca7262ba1e8bce SHA512 d42f6734edc5c159f15b9c020deb2595f32bbcdf53ecfaea840afb38314a855d09315693129393f755fdc3295b5965073b404822aacf1a149c7f9bab89c48fd5
+EBUILD ml-dtypes-0.2.0.ebuild 963 BLAKE2B b42e2e5c41d82347349111f30884e6483492cb6e7c54d1290c12df202ecfb4781760d9febe7c8a76140ed7795b18f77db4c4373a4033181e5119d5886ff27198 SHA512 a9e1469b6345bfd7eac002a289df39552e75211e0f4be6bd18e9ed0333c0efb69a8efb4677e213603c6d8e1d4ba0da335535b55ae06a3b4ddbb3da0a59f4cf2a
+EBUILD ml-dtypes-0.3.2.ebuild 963 BLAKE2B b42e2e5c41d82347349111f30884e6483492cb6e7c54d1290c12df202ecfb4781760d9febe7c8a76140ed7795b18f77db4c4373a4033181e5119d5886ff27198 SHA512 a9e1469b6345bfd7eac002a289df39552e75211e0f4be6bd18e9ed0333c0efb69a8efb4677e213603c6d8e1d4ba0da335535b55ae06a3b4ddbb3da0a59f4cf2a
+MISC metadata.xml 375 BLAKE2B e33994ac1d1d55727a93c05f39906bf1e462771b06f01fa6c0508f491a226db5ec896dfc95c0f4f03f68b975c24aa6dadcf8b766d1500d77bef32d8713357c48 SHA512 9123403aa5d1320cc9a1ed6b5cc843372812d10c7dce3d1a7b521005c47e9b98aad218c2b6e545eca44a80ac26ad697e8b4518b14b449cac402ed25fd749b784
diff --git a/dev-python/ml-dtypes/metadata.xml b/dev-python/ml-dtypes/metadata.xml
new file mode 100644
index 000000000000..a0436bcc589f
--- /dev/null
+++ b/dev-python/ml-dtypes/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ <name>Jason Zaman</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jax-ml/ml_dtypes</remote-id>
+ <remote-id type="pypi">ml-dtypes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ml-dtypes/ml-dtypes-0.2.0.ebuild b/dev-python/ml-dtypes/ml-dtypes-0.2.0.ebuild
new file mode 100644
index 000000000000..2c22d3c56d02
--- /dev/null
+++ b/dev-python/ml-dtypes/ml-dtypes-0.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PNGH="${PN/-/_}" # pypi is ml-dtypes, github is ml_dtypes
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+EIGEN_CommitId="7bf2968fed5f246c0589e1111004cb420fcd7c71"
+
+DESCRIPTION="A stand-alone implementation of several NumPy dtype extensions"
+HOMEPAGE="https://github.com/jax-ml/ml_dtypes"
+SRC_URI="
+ https://github.com/jax-ml/${PNGH}/archive/refs/tags/v${PV}.tar.gz -> ${PNGH}-${PV}.gh.tar.gz
+ https://gitlab.com/libeigen/eigen/-/archive/${EIGEN_CommitId}/eigen-${EIGEN_CommitId}.tar.bz2
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pybind11[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ rmdir third_party/eigen || die
+ cp -r "${WORKDIR}/eigen-${EIGEN_CommitId}" third_party/eigen || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild b/dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild
new file mode 100644
index 000000000000..2c22d3c56d02
--- /dev/null
+++ b/dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PNGH="${PN/-/_}" # pypi is ml-dtypes, github is ml_dtypes
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+EIGEN_CommitId="7bf2968fed5f246c0589e1111004cb420fcd7c71"
+
+DESCRIPTION="A stand-alone implementation of several NumPy dtype extensions"
+HOMEPAGE="https://github.com/jax-ml/ml_dtypes"
+SRC_URI="
+ https://github.com/jax-ml/${PNGH}/archive/refs/tags/v${PV}.tar.gz -> ${PNGH}-${PV}.gh.tar.gz
+ https://gitlab.com/libeigen/eigen/-/archive/${EIGEN_CommitId}/eigen-${EIGEN_CommitId}.tar.bz2
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pybind11[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ rmdir third_party/eigen || die
+ cp -r "${WORKDIR}/eigen-${EIGEN_CommitId}" third_party/eigen || die
+ distutils-r1_python_prepare_all
+}