summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
commit7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (patch)
tree02bad8e4f1f060d4858a1a2ec3fc9404f0b7a197 /dev-python/mkdocstrings
parent43c2a85d4e20318dd3d35872e348707900870067 (diff)
gentoo auto-resync : 07:05:2024 - 00:00:56
Diffstat (limited to 'dev-python/mkdocstrings')
-rw-r--r--dev-python/mkdocstrings/Manifest2
-rw-r--r--dev-python/mkdocstrings/mkdocstrings-0.25.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings/Manifest b/dev-python/mkdocstrings/Manifest
index 8a57cb2f9b68..dad7ee1e3a51 100644
--- a/dev-python/mkdocstrings/Manifest
+++ b/dev-python/mkdocstrings/Manifest
@@ -1,5 +1,7 @@
DIST mkdocstrings-0.24.3.gh.tar.gz 88575 BLAKE2B a8567868e1572104773a0ca739966a4d6f5c13e02f29dfb0cfd68fe8cbe9c44805adb8fa029489e057b136e37f3587edebc2ec3e18d73d5eadc05a494a4d2ea5 SHA512 a93b1b07137c8403c5e049a57f0c26c629cbc37112181eae141390bd2863826d17c32e93a626a3627c56242a4227954885e81000122227ce1cd7dc8698c67b37
DIST mkdocstrings-0.25.0.gh.tar.gz 89714 BLAKE2B 536bce1178b7f9ca3cf25d73ea6c5a9533f80b4453520ac4681cac845c9a3016cdc184bb676528953e5b79efb27c4acd87912205c231e295ffca9cd4549cb31a SHA512 2e938bbcc2d6b3fb5c7805a5371f458f962af7db288fdfa3ae1ca38d948d0c6d8280425171276d2181f5213da971dfbb6554b23130d66177d1da8a2f235bb1d1
+DIST mkdocstrings-0.25.1.gh.tar.gz 89869 BLAKE2B 248436eeabafbb7cbee27362b43d2feadeadda7692b5843621bd97261e17a93783c38f37850700c6e79b7f23f15fdc8f21567329afba9b4fb0618f277acc1865 SHA512 155dc5d15fd71f9c5dbd5d5f70f380ad5197fc0c1dc0fe722205b30decbd19307daa631d3a4a40206cdf36981f414ea1a4c001d8cef517ffed569e96ea0e8302
EBUILD mkdocstrings-0.24.3.ebuild 1821 BLAKE2B eeb8dc567446318a94e71266430fe1004c7138045a5a9bcba49a90a545e28e74b1b60a4c0631471e5437b6f2f6029feaf7e1bee1be2e629b92289938537bc2db SHA512 0fe9b9b4e3f98f696f3abba8841abaa3a2a430b2e68abe1ec4068b5d9d3b1bb0db70a1a6a851aca2b5c85f43840f52be0daaf1b6118899b76aff8fe67a5043d6
EBUILD mkdocstrings-0.25.0.ebuild 1821 BLAKE2B eeb8dc567446318a94e71266430fe1004c7138045a5a9bcba49a90a545e28e74b1b60a4c0631471e5437b6f2f6029feaf7e1bee1be2e629b92289938537bc2db SHA512 0fe9b9b4e3f98f696f3abba8841abaa3a2a430b2e68abe1ec4068b5d9d3b1bb0db70a1a6a851aca2b5c85f43840f52be0daaf1b6118899b76aff8fe67a5043d6
+EBUILD mkdocstrings-0.25.1.ebuild 1821 BLAKE2B eeb8dc567446318a94e71266430fe1004c7138045a5a9bcba49a90a545e28e74b1b60a4c0631471e5437b6f2f6029feaf7e1bee1be2e629b92289938537bc2db SHA512 0fe9b9b4e3f98f696f3abba8841abaa3a2a430b2e68abe1ec4068b5d9d3b1bb0db70a1a6a851aca2b5c85f43840f52be0daaf1b6118899b76aff8fe67a5043d6
MISC metadata.xml 410 BLAKE2B 896cd2e10ca1ef3d76b5cf37b5f2a89f12df1f068a5a423c27e51e4f1d60261ed0198ee11ca0b838cae0dfd2891e3ea7ffbe071d72c69f9f83a89ae42ae656a9 SHA512 3b2e9deab0dc2f17bc6e2e5c25e5b27c084cc5027fae2f84b31f16da9409fc28bbc75a6ea0ee96bb51555e6e61275a472bf7d0c1b2ae4a4d8ca469f0d0280660
diff --git a/dev-python/mkdocstrings/mkdocstrings-0.25.1.ebuild b/dev-python/mkdocstrings/mkdocstrings-0.25.1.ebuild
new file mode 100644
index 000000000000..80d4bac4ae7b
--- /dev/null
+++ b/dev-python/mkdocstrings/mkdocstrings-0.25.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatic documentation from sources, for MkDocs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/
+ https://github.com/mkdocstrings/mkdocstrings/
+ https://pypi.org/project/mkdocstrings/
+"
+# Tests require files absent from PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/mkdocstrings/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.3[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-1.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.5[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-autorefs-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-6.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/markdown-exec[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings-python[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+# mkdocstrings documentation generation requires several currently
+# unpackaged mkdocs extensions and plug-ins, and this test
+# makes use of mkdocs configuration
+EPYTEST_DESELECT=(
+ tests/test_plugin.py::test_disabling_plugin
+ # WTF, it tries to unlink installed files from installed package?!
+ tests/test_handlers.py::test_extended_templates
+ # Needs unpackaged mkdocs-callouts, mkdocs-literate-nav, and possibly more
+ tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file
+ # Internet
+ tests/test_inventory.py::test_load_inventory
+)
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}