summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-05 17:54:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-05 17:54:48 +0100
commit8679463887b182c233b55d8112534d7d7dcde08b (patch)
tree3c45a448a6022fda1b09ac5ef94b5c02ddcc9b30 /dev-python/mkdocstrings-python
parente8c80f80fd116cc679f261d8bc6ee6c9bfc3f0a0 (diff)
gentoo auto-resync : 05:10:2023 - 17:54:48
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest2
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.7.2.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index 20d4508aaf04..0c07a45cef68 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1,5 +1,7 @@
DIST mkdocstrings-python-1.7.0.gh.tar.gz 136113 BLAKE2B a1ccb8ff817beaa89fb8234c60920a3b60e57d3908e103279728a9b0d6c4b53132da5262001b9a0e89b161e5e96226ddd06e0b224db4c869cb99297a6c646167 SHA512 2e1b855c8ad51b8066e3ff1036cf6d0ee90b766f7f851a6045707889e39ca9217f9a747bff0069614e89154356224a670b4de6f8a678439bbff63d4e3ffb6b70
DIST mkdocstrings-python-1.7.1.gh.tar.gz 136263 BLAKE2B c3c5661f7afd94c4233bd737ff1129f280825a6acc6c868867443e3eab76f4d22732895de486784f0c3f163ded45e7c9a6954768f13fde3bfc1404e76ea9224b SHA512 dfa05086d12805975e68bebabc47e2bfdeca67c7dc799312e3d719142b7bea995f06ed8c5b4699ffbb58647e0a1f6be23dc17a76ff8c7008587ccc3af72c56f9
+DIST mkdocstrings-python-1.7.2.gh.tar.gz 136510 BLAKE2B de1926caf358d858de63dd84261699aaedf9f12e74affeda9b6fb3ca93dd1ddb80aa02aa2bdf1b820564b0ea05c26cce14f7d9aaca37a151314fc449695745c9 SHA512 2aeb2c4f62054188d8075babf0e131107f8ba4355444b793e39a29b95702d6b3b26b6862fc5c48d30bdc4af1fc798c994ede8e96f608cd0a59852368ca1e46f3
EBUILD mkdocstrings-python-1.7.0.ebuild 859 BLAKE2B 926a9c55b502d6313dee12dfe777e90ca9573eb787b2fe5129e29c99a034e42f649ef64bead7de1beb3f4a97d1b1b1a5ed2a18bb7989e7d62e750a4f39b72cff SHA512 6a66967c086389d4d6cc7573a1b3c55926fb16cc1545f0c4fa3c89aeb94d4639edeeb2cafe7002a4a28e4eb68f8c8d90e0960a5620f2f3810b4d54df2540d578
EBUILD mkdocstrings-python-1.7.1.ebuild 859 BLAKE2B 926a9c55b502d6313dee12dfe777e90ca9573eb787b2fe5129e29c99a034e42f649ef64bead7de1beb3f4a97d1b1b1a5ed2a18bb7989e7d62e750a4f39b72cff SHA512 6a66967c086389d4d6cc7573a1b3c55926fb16cc1545f0c4fa3c89aeb94d4639edeeb2cafe7002a4a28e4eb68f8c8d90e0960a5620f2f3810b4d54df2540d578
+EBUILD mkdocstrings-python-1.7.2.ebuild 859 BLAKE2B 926a9c55b502d6313dee12dfe777e90ca9573eb787b2fe5129e29c99a034e42f649ef64bead7de1beb3f4a97d1b1b1a5ed2a18bb7989e7d62e750a4f39b72cff SHA512 6a66967c086389d4d6cc7573a1b3c55926fb16cc1545f0c4fa3c89aeb94d4639edeeb2cafe7002a4a28e4eb68f8c8d90e0960a5620f2f3810b4d54df2540d578
MISC metadata.xml 411 BLAKE2B 0ac98abc8de945139a73e2083e8c04df749bd8c0c26c446df65218057182391ae025885fa5c5bde2d1139dde9916aa3baa0426d70b57326563c3fdaf466a20d8 SHA512 c7ec032c8ae7197452714dc2b541ccad1cf84d7844dafc4e7581ffb00c62c0fd2c38d453e62a7706d74d2d20146acdf1e99e502ab8bd8976acfd6f5a605e1c56
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.2.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.2.ebuild
new file mode 100644
index 000000000000..f0b94cc2c39d
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.35[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}