summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-15 04:39:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-15 04:39:16 +0100
commit80765b090d10ae3f68b00e3befe5859f7212e536 (patch)
treed624666bb07bce025925d07a966e0fa276bc00c4 /dev-python/mkdocstrings-python
parent9f1c285c267548022db687a4fe85501b006d68b7 (diff)
gentoo auto-resync : 15:07:2023 - 04:39:16
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest2
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.2.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index f98ab44b4059..ce385baa2e37 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1,3 +1,5 @@
DIST mkdocstrings-python-1.1.2.gh.tar.gz 127162 BLAKE2B 1aa77a6846b8f4787091691c3862428400cf73e5b51f3d7a278e9d871136a3693d80a1fe79d6999dedefe66b0a14402e0d70c448f9260c1528024a56cf223c69 SHA512 40c8247bc6217e73c23555fb3de14ddc8995e1870c7bcee85c12c885b9710cd303da3cec22b4ae44ff5de050486958447d2d489d9739b9860c432e9e00fec0d7
+DIST mkdocstrings-python-1.2.0.gh.tar.gz 132100 BLAKE2B 8873ea65a799f5f8d6bf4a792abb94edc70e8acb0140dfa30dda15d9d94e354fe4c32c99dde5c53c2c04af7591762c50c5c2cf4fb7a8e167e2065c6d6da0aba1 SHA512 f2e07ad52a5102b178a5bc9245c018319b52f37d11fdf1650f3568275fe7d7800938d699a2ef1c6343f21187d47b34b0374ddbfb0cc04891a462480533043f72
EBUILD mkdocstrings-python-1.1.2.ebuild 852 BLAKE2B 7086ff7a9e070b5e2c96123f723e6f8b199bc199ced95066ed2bf6caa4536e87a2b06d19ee87975374fb2217b1650dd83e61d0cf9c23ba868d05aa865afe9d0c SHA512 db9067524986809071cc8403c3516045ccb875380df27df98b04c36df2f6f96a50bc94a9054284fefb7a978f46ea3a6c4f8aabb9fb05f96b600bbf16732438f5
+EBUILD mkdocstrings-python-1.2.0.ebuild 861 BLAKE2B 7c7c0491dc73801d217fcac26f68c768599c81c5abd64dcbbe41dae2ede7ce3906289d520b3f3b06c83d89aede77f5648036f4e845e11b30941700d7ed5cc30d SHA512 8d9be4de760da3db801a607085342c35dd8bd448ecda072446367340805a8eb046a15b5bb5a89c3621ba8c25ccfceb0eb7bf0102ed42a323e52b5814db66209a
MISC metadata.xml 411 BLAKE2B 0ac98abc8de945139a73e2083e8c04df749bd8c0c26c446df65218057182391ae025885fa5c5bde2d1139dde9916aa3baa0426d70b57326563c3fdaf466a20d8 SHA512 c7ec032c8ae7197452714dc2b541ccad1cf84d7844dafc4e7581ffb00c62c0fd2c38d453e62a7706d74d2d20146acdf1e99e502ab8bd8976acfd6f5a605e1c56
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.2.0.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.2.0.ebuild
new file mode 100644
index 000000000000..44a4ca132d47
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.30.0[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}