summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 09:38:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 09:38:07 +0100
commit4d9aef45678c7cb55b24107642790224ab8c153b (patch)
treeb1c56639785aeba23901272429a46e4e872a7711 /dev-python/mkdocstrings-python
parentf09a6cf772eb2f757f0fc49f3297d6a095a10aa5 (diff)
gentoo auto-resync : 19:08:2023 - 09:38:07
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest2
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.4.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index 9142f98735d5..af7f1dc004eb 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1,5 +1,7 @@
DIST mkdocstrings-python-1.2.1.gh.tar.gz 132468 BLAKE2B 287cae20510818c085bf505fea0f74e39df86538e19bfcb90aa7f6d46fb237158979dc65c7f955d73461fadb4ed35263ef47b9771f224b5793026a9f0b3c86e1 SHA512 147849a88c3bb5347c1cb4293c9ee9c54cb33933bc274dc5bc933f72deb64016c7f7b8ba817311e282c68606d0980571d5713dec7a47e8d6c51168d524af7d97
DIST mkdocstrings-python-1.3.0.gh.tar.gz 132776 BLAKE2B 894068067f301f40ed9535cd929fdbd40aa396c9c09c0cee7887f50669465cd0422c0b9b240553193df7e7d4c90f0bf2b591000e6568ee3c47256fc5d1f79179 SHA512 caf806d6285281ef84ed78bd6295ec6732d454a602f55f825436d0a17e9ab62e33ac21510d0ccee5d33fb3c117ec416859ad90ce75d608649a277342d1dc5a1c
+DIST mkdocstrings-python-1.4.0.gh.tar.gz 133783 BLAKE2B 6f9f0e157f9b9baa097366690c46e6fd3b8a2a7626eb3cc2c182a37ebb8d9fca55d8eb040f4c43aa1ef52c956e4d258c51a427ce7e7e04eec97d1ab32a2355f6 SHA512 c949180cc3fcfa809fad00374de9030ef6f2f8061251cf0e5857272908fdf9db6626d1f8c8de2a438dd8f7a5256b9e5daa2930519a4ab6324039b6555f547f6b
EBUILD mkdocstrings-python-1.2.1.ebuild 861 BLAKE2B 7c7c0491dc73801d217fcac26f68c768599c81c5abd64dcbbe41dae2ede7ce3906289d520b3f3b06c83d89aede77f5648036f4e845e11b30941700d7ed5cc30d SHA512 8d9be4de760da3db801a607085342c35dd8bd448ecda072446367340805a8eb046a15b5bb5a89c3621ba8c25ccfceb0eb7bf0102ed42a323e52b5814db66209a
EBUILD mkdocstrings-python-1.3.0.ebuild 904 BLAKE2B 81b1b24e019f3a0ca5f1985ac5360bd00e0597d319ef2b27a3dde4ebcf1d189d285cd5466d1cc2e8ce91d4a9ed4f4572b3b490c04820a44ecbed500ca02d6a9a SHA512 75c785a810d602c15c8e852e3baf9578c1bed623071c026d9040f1e2a62bae2273af7c133a61d1e02c2d07a4a8db0a79a8f494625e0cbc720b56772ec1aa7606
+EBUILD mkdocstrings-python-1.4.0.ebuild 859 BLAKE2B cf0a61dd35c159a9b44b31fc520e93abecabf6590c5b21455e84a2d50a742164757ae1923a1233211f912575c6c8f5bbc3a47ebf0049e4e4fc068fd729fd46e7 SHA512 87159cbcdea4c6822fdefd886ca003609060e073ff3256fbb23a64ca332b704d5d7be9235dc10b3bdc7ed5a75efad1bf9a788b40dafc336cbdf9100d8d0e91d6
MISC metadata.xml 411 BLAKE2B 0ac98abc8de945139a73e2083e8c04df749bd8c0c26c446df65218057182391ae025885fa5c5bde2d1139dde9916aa3baa0426d70b57326563c3fdaf466a20d8 SHA512 c7ec032c8ae7197452714dc2b541ccad1cf84d7844dafc4e7581ffb00c62c0fd2c38d453e62a7706d74d2d20146acdf1e99e502ab8bd8976acfd6f5a605e1c56
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.4.0.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.4.0.ebuild
new file mode 100644
index 000000000000..045b30f98097
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.33[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}