summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
commitf6a034d922bf54efeaa781fcb5388b325b90d945 (patch)
treeb9fafda6cf44bf7b09de2c3d74090de10f9cde04 /dev-python/mkdocs
parent007b0aae027279095b8605c214b535e59df8f6eb (diff)
gentoo auto-resync : 03:05:2023 - 11:25:06
Diffstat (limited to 'dev-python/mkdocs')
-rw-r--r--dev-python/mkdocs/Manifest2
-rw-r--r--dev-python/mkdocs/mkdocs-1.4.3.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/mkdocs/Manifest b/dev-python/mkdocs/Manifest
index e00ed36bd2b2..80fa3d7ed944 100644
--- a/dev-python/mkdocs/Manifest
+++ b/dev-python/mkdocs/Manifest
@@ -1,3 +1,5 @@
DIST mkdocs-1.4.2.gh.tar.gz 4018656 BLAKE2B 325e940c72f6a8fe7f353a4ba2f65fc6b123c5be04173e5469d3165d25b3d6bb8983b5c541b0d1376770a8205b54860b756eca1719decdd77e7e4c57477998e4 SHA512 cabdb86a5934672645e29055c04f5c877dd5527df909a606d94f930211cec9f4f29f89137dd413238c07af4108d870dd3b880cba447c55690583cd1b13b179b7
+DIST mkdocs-1.4.3.gh.tar.gz 4019852 BLAKE2B 4bf0d47d939fc9db0daa7954857ba35d7a48031d6029b1a0a1680b6bbe13890244b29d670efe9a0d2f18e1e73aab75879f4e7bcfc60cf944e816054a970ba8e6 SHA512 ac023f0e91f32faa38843c5ec42eb8aa32439b5a7e3967b9838f845687d0c7eadb3c13cbd4f1270e026a4b5afe15123d1568375f75a1ca07a28a93a595f5ac6b
EBUILD mkdocs-1.4.2.ebuild 2433 BLAKE2B ad914ff3892c41d25e4abf25d44fe26fcbe1ebc78ad455101d3de63dce8d04061893a0d4799682565ad58e190a01b5545aa3505510483ceecfc73c3500abbfd1 SHA512 b9d2679d088fd374fc8092e9554894a181f635a8e5eed0950fe9348028d77822bfafb231f631697f41918f812ccfcf206ee600c00589b7b0d6bf53a78b9aa3ba
+EBUILD mkdocs-1.4.3.ebuild 2508 BLAKE2B 9cccc6ad65c0f0daed13425df6f55d62d6e075523675f12bb7ec41720e52831a4c6c7ed3d3692dd497206aec499b72ec0e6b1de67d5027e1dd64b965fe95af86 SHA512 edfab3bf7ea723ee758b0543c6a465897359ff07e667621419237d8a168650545d776c34dc34a377290112704adbd32410c3229607832264a12057ef4e069d5c
MISC metadata.xml 405 BLAKE2B de9dd789fea13afc3622c6961674d046806db1025e9d0475c0ff8bfe1c6d91a741b6112ccaafb46cb19b9dac971c50095ac89b13353c7c0e1571961a19a90387 SHA512 7a19785dbacb67aa5679d6e7c9617b52b25f724430fa3471b645e31df04157efc4060dbd4fccbfc37b5709138164d8ec89c2e94cddfd727b3ee4c705ddd38dcf
diff --git a/dev-python/mkdocs/mkdocs-1.4.3.ebuild b/dev-python/mkdocs/mkdocs-1.4.3.ebuild
new file mode 100644
index 000000000000..d35b6cee4f76
--- /dev/null
+++ b/dev-python/mkdocs/mkdocs-1.4.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Project documentation with Markdown"
+HOMEPAGE="
+ https://www.mkdocs.org/
+ https://github.com/mkdocs/mkdocs/
+ https://pypi.org/project/mkdocs/
+"
+SRC_URI="
+ https://github.com/mkdocs/mkdocs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+# https://bugs.gentoo.org/873349
+# Building documentation requires packaging: callouts and mkdocs-autorefs
+#
+# IUSE="doc"
+#
+# BDEPEND="
+# doc? (
+# $(python_gen_any_dep '
+# dev-python/mdx_gh_links[${PYTHON_USEDEP}]
+# dev-python/mkdocs-redirects[${PYTHON_USEDEP}]
+# ')
+# )
+# "
+RDEPEND="
+ >=dev-python/Babel-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.3.3[${PYTHON_USEDEP}]
+ <dev-python/markdown-3.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.0[${PYTHON_USEDEP}]
+ >=dev-python/ghp-import-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml_env_tag-0.1[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.5[${PYTHON_USEDEP}]
+ >=dev-python/mergedeep-1.3.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Tests fails if additional themes are installed
+ mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes
+ mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes_error
+ mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes_warning
+
+ # Does not work in emerge env
+ mkdocs/tests/config/config_options_tests.py::ListOfPathsTest::test_paths_localized_to_config
+)
+
+python_prepare_all() {
+ # livereload has been dropped in this release, this test is a remnant
+ rm mkdocs/tests/livereload_tests.py || die
+
+ # Does not work in emerge env
+ sed -i -e 's/test_paths_localized_to_config/_&/' \
+ mkdocs/tests/config/config_options_tests.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ default
+# if use doc; then
+# # cannot just do mkdocs build, because that fails if
+# # the package isn't already installed
+# python -m mkdocs build || die "Failed to make docs"
+# # Colliding files found by ecompress:
+# rm site/sitemap.xml.gz || die
+# HTML_DOCS=( "site/." )
+# fi
+}
+
+python_test() {
+ epytest '-opython_files=*tests.py' mkdocs/tests
+}