summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-git-revision-date-localized-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-python/mkdocs-git-revision-date-localized-plugin
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-python/mkdocs-git-revision-date-localized-plugin')
-rw-r--r--dev-python/mkdocs-git-revision-date-localized-plugin/Manifest2
-rw-r--r--dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-0.9.3.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest b/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest
index ddaa9edbb84d..bb2ea41841ca 100644
--- a/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest
+++ b/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest
@@ -1,3 +1,5 @@
DIST mkdocs-git-revision-date-localized-plugin-0.9.2.tar.gz 367301 BLAKE2B ac4d69117dea856a209d144e452cf408ee3d111eaa8a9825602b9f8d604a79143e96a51e67b74e430eecc6ee33335161e409149220a8b216f3b47f22e7a49f12 SHA512 11714323a6e300d0d8d05198f617019158dc48ba43e8a685f52702da7f52558f1358dfce294dcd421ba9d59131c17e4d6ea6ff483397055dee62dffb76032d4c
+DIST mkdocs-git-revision-date-localized-plugin-0.9.3.tar.gz 367885 BLAKE2B 3c7aa4a5cfcb585c022c9a652ff0b5be8c309298f69c69973a9442913ac4d12f14a3f5783627d9574cffc9c438e98678641d58e77f6712e0ddf68ac77ee098fa SHA512 8a345770a6f40bacc0899a7fcf3d056874f3a947ffbd001bd5885ef88e813e4d405ab7d7a06be3adb5ef34d5ef1f449432b0e9594b79a9d4a9350901c692cc10
EBUILD mkdocs-git-revision-date-localized-plugin-0.9.2.ebuild 1416 BLAKE2B 8a1f5230ee1befd6ee7faa3b867f4bddd1de2b0d387c5d4875d95b93ab79f1c7a2211a735bdf6f7881d8095ecded6e8b226bab60ab90603ccffc587e7a88b00f SHA512 8ae55c9b5a36010a1918b316f83b9506e722bc4d52c8be57bb6983cb0ec381359dce554f94769206504f6ea6498c90a8a8c08dff5fe373dd64daf06b54321223
+EBUILD mkdocs-git-revision-date-localized-plugin-0.9.3.ebuild 1274 BLAKE2B 5ee43ebbc5c87f584b8af4aef01071b6281a89bfa3df5baf70882c93a440446fb9a896de1cdcd7b4ea1ae10845775c977606fd50ed04fba4b1561d4fcc32744c SHA512 73065aff3587edbb1498ce05affa4c0b00307b491a3d5b756e4118295f0f46f35fe5f23098fcbd14dff4aba5237b4f9525bd4f259bae5584193f418f7c1a8b59
MISC metadata.xml 595 BLAKE2B 930979c48f81e50af6d892a4c66f93851d862cf0e0562ad6e6f9f903b4aa6db3a3d989e7ac45ac1d5f5ebfce27bf718e143587eef5890695c86c08bd66050118 SHA512 58e5db1bd1f0e6c613ba2957fa4d2d6ff34c067ce29a67bf4171235f38a4cbd57c5d8cc5e5687176f6ac270798ee9694a20dc64a8b720fc03119b5964f8401a1
diff --git a/dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-0.9.3.ebuild b/dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-0.9.3.ebuild
new file mode 100644
index 000000000000..e2e2a13e05a7
--- /dev/null
+++ b/dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-0.9.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Display the localized date of the last git modification of a markdown file"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-revision-date-localized-plugin/
+ https://pypi.org/project/mkdocs-git-revision-date-localized-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+ doc? ( dev-vcs/git )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin's tests need git repo
+ if use test || use doc; then
+ git init -q || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -qm 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}