summaryrefslogtreecommitdiff
path: root/dev-python/mkautodoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/mkautodoc
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/mkautodoc')
-rw-r--r--dev-python/mkautodoc/Manifest2
-rw-r--r--dev-python/mkautodoc/mkautodoc-0.1.0-r1.ebuild (renamed from dev-python/mkautodoc/mkautodoc-0.1.0.ebuild)16
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/mkautodoc/Manifest b/dev-python/mkautodoc/Manifest
index 2ff33fcfd557..096207dd8e12 100644
--- a/dev-python/mkautodoc/Manifest
+++ b/dev-python/mkautodoc/Manifest
@@ -1,3 +1,3 @@
DIST mkautodoc-0.1.0.tar.gz 5654 BLAKE2B c0ae754e800ea25e9cccc621b4fd5c8d1561c57808b301ac5a3036ca18fda1adc432006e13b777a83dcc2cd6960a34745e17dfbcbbda24098902198d4fc9d743 SHA512 7ccb0a03016e2984d88d78eca2a8ee01e2153ff574c912358640c158b2084e3c365ace0fdb89cb74bb1950c68775d9d3cb11201cbf3c6d136dc7886a3294dc89
-EBUILD mkautodoc-0.1.0.ebuild 605 BLAKE2B cfc9f5ab3c8c01e45fecadd39b05adeb8868d61a42ce83068bc771800b0be17a7583be42f41e0238f2484cb6a329dca587b19bb7f569966b76b5abf8223b84a0 SHA512 6a44b800e8718310d30c0330b722aed3a3e82f1ecaaf07dda0a7d1b7231560c6939945d80d8f25bad2031927fa5f9017f3ca6b36febd84c3dcd7da4bbfb66854
+EBUILD mkautodoc-0.1.0-r1.ebuild 711 BLAKE2B 63a80be760fa044836598ce7f8302cd1b0df3c9e2e6e61095083df33a30de0f8c2e65f0688599b03820a4634da0aad2ef1e27741982ad6e7006f323c4e60cde0 SHA512 85e5b11be1c5dfadc160261040cd7a741869566e8108c41b342ed5cae6ce68ebafbf8c65ad58eb4e7ff792629fbcc0cf638f850f8aa4a22cbe778cd3b34f4fe7
MISC metadata.xml 517 BLAKE2B 982eb0e73c28e8565ebcd08f9822e5d35258e8cb1f44b57a3218b928c6d9873b1d5ae8890d4688ca4775806aa140c3be3ba52c9af8afe87f7ba2e89ae09c1e97 SHA512 640db2d746a27484dcdbd4d84951dd207a0ec6ce9047346432fddc1b08ad98f19077d320c603a85297161c8202dd1c5328486280c343987976a3108667978a51
diff --git a/dev-python/mkautodoc/mkautodoc-0.1.0.ebuild b/dev-python/mkautodoc/mkautodoc-0.1.0-r1.ebuild
index 228c3dfefd11..05071c660cc5 100644
--- a/dev-python/mkautodoc/mkautodoc-0.1.0.ebuild
+++ b/dev-python/mkautodoc/mkautodoc-0.1.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Auto documentation for MkDocs"
@@ -20,9 +20,13 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+)"
+
distutils_enable_tests pytest
python_test() {
- PYTHONPATH="${WORKDIR}/${P}/tests/mocklib:${WORKDIR}/${P}"
- epytest
+ PYTHONPATH="${WORKDIR}/${P}/tests/mocklib:${WORKDIR}/${P}" \
+ distutils-r1_python_test
}