summaryrefslogtreecommitdiff
path: root/dev-python/mitmproxy_wireguard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-19 01:49:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-19 01:49:34 +0100
commit37cd441738bc6681ca075c01b6dd06056a27abbf (patch)
tree528a97a3994f491e0909f7e236f1691667ecbe77 /dev-python/mitmproxy_wireguard
parent1494784ae35c6fa7b6a92a80dea93265fc54ccd0 (diff)
gentoo auto-resync : 19:06:2023 - 01:49:34
Diffstat (limited to 'dev-python/mitmproxy_wireguard')
-rw-r--r--dev-python/mitmproxy_wireguard/Manifest2
-rw-r--r--dev-python/mitmproxy_wireguard/mitmproxy_wireguard-0.1.20.ebuild398
2 files changed, 203 insertions, 197 deletions
diff --git a/dev-python/mitmproxy_wireguard/Manifest b/dev-python/mitmproxy_wireguard/Manifest
index 8d4988f7e111..06dbf2e8f4c0 100644
--- a/dev-python/mitmproxy_wireguard/Manifest
+++ b/dev-python/mitmproxy_wireguard/Manifest
@@ -193,5 +193,5 @@ DIST windows_x86_64_msvc-0.42.0.crate 659377 BLAKE2B f01dbfcb86dcb7301790a1a7046
DIST x25519-dalek-2.0.0-pre.1.crate 88717 BLAKE2B 6b4970f31dd1ae23016bee1e879dd7486e2bde5fefe7de5b934321bcf8360e6c033631856b05bc4e176fc4e4803a75139ac07659be2006d3ba5eee6c883bd6f8 SHA512 f8355a79c469d1e3c9ff38a435b0520a7db05467156e7974f9e56a13a5c3fa82934fa6522523e8bb10570b3b9fcb6fbf95dd357ba0cd18455ff97255b48f0371
DIST zeroize-1.5.7.crate 18861 BLAKE2B 5f203d91aae732b928e2acd02656a486f0f930b8daea96b927552f5790862489d83c7bd48b0c7c62a3273e7a04833a16149ce489847f17fbb037e88922d359a2 SHA512 e0688681bceba324d36ea4dc552791801dc93b5882d106b79dd317af99cb718b711899bfd09917a811d23096693448801e64f0651bd9eeae7895618821d88fa9
DIST zeroize_derive-1.3.3.crate 10380 BLAKE2B 5ed1fd50f483e1eeec54584adb3d6e20f12987037edf859bd0ca1e9274c41be332edfd4a294d25a96ec811ab06299185148702f4317dbcf1c5e0a23e7e8116b0 SHA512 cfe53287c80866868ca435414efba32267f68b6b95dca9c11201365c9fc21444b1ca926fe8a2dd64c0978a8691e351108538bc7e1fc6f60feb83dde93f56b3c3
-EBUILD mitmproxy_wireguard-0.1.20.ebuild 4401 BLAKE2B 29d989531b8719b987be70a98a1bdc1661684224578aa59988ddb83c78899799ca08c42bb621edb2d32968130e2e598562d5bbacb672c08fd31b1ded5dfa72eb SHA512 9581b63297026dd88913590bd35dbfd5cac8159ff8be52859a3934e56daeddadeb7326f5498b58de37c08906f217d238b16a089b22b75ede26d3e13ec5ae0d40
+EBUILD mitmproxy_wireguard-0.1.20.ebuild 4497 BLAKE2B e4f36c9560e129f0ea2f56e403a951396674a209609fc811dfa6fce15b0993ad254ed256ef40c3a37c03cf2cd2eef5d081596a441c842df5335cc4bc063ceeb1 SHA512 a819c6cd7c9372dcc7e424fe8ec1f948427f418f30592e8a9e0d56e7ca3154fc51d5a712062aeb7e1c9bf97da0e16c9cc88ec6b82dd8dc14c38a567844f3fdfa
MISC metadata.xml 400 BLAKE2B bbf04eceaeaa26baff40480b9136d00095c1dddc92fc4ff8c98c5ce313a373731f3b54cdc8f631f86c0bc1fab00684c97b4bbff26d90199f6ec8527067a90a85 SHA512 121b90819b7b1f28017c07e1565758925bf5ea70e93d1f8c421dd3e8a8166f05bbca69a0eb8c5e888acdf81708b21ef6c17737338aa2599985eca79f175c212e
diff --git a/dev-python/mitmproxy_wireguard/mitmproxy_wireguard-0.1.20.ebuild b/dev-python/mitmproxy_wireguard/mitmproxy_wireguard-0.1.20.ebuild
index 376a3627f7e6..18f4d27e3683 100644
--- a/dev-python/mitmproxy_wireguard/mitmproxy_wireguard-0.1.20.ebuild
+++ b/dev-python/mitmproxy_wireguard/mitmproxy_wireguard-0.1.20.ebuild
@@ -3,204 +3,205 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=maturin
PYTHON_COMPAT=( python3_{9..11} )
CRATES="
- adler-1.0.2
- aead-0.5.1
- aho-corasick-0.7.20
- anyhow-1.0.68
- arc-swap-1.6.0
- async-stream-0.3.3
- async-stream-impl-0.3.3
- async-trait-0.1.61
- atty-0.2.14
- autocfg-1.1.0
- axum-0.6.2
- axum-core-0.3.1
- base64-0.13.1
- bitflags-1.3.2
- blake2-0.10.6
- block-buffer-0.10.3
- boringtun-0.5.2
- bumpalo-3.11.1
- byteorder-1.4.3
- bytes-1.3.0
- cc-1.0.78
- cfg-if-1.0.0
- chacha20-0.9.0
- chacha20poly1305-0.10.1
- cipher-0.4.3
- console-api-0.4.0
- console-subscriber-0.1.8
- cpufeatures-0.2.5
- crc32fast-1.3.2
- crossbeam-channel-0.5.6
- crossbeam-utils-0.8.14
- crypto-common-0.1.6
- curve25519-dalek-3.2.0
- digest-0.9.0
- digest-0.10.6
- either-1.8.0
- env_logger-0.9.3
- flate2-1.0.25
- fnv-1.0.7
- futures-0.3.25
- futures-channel-0.3.25
- futures-core-0.3.25
- futures-executor-0.3.25
- futures-io-0.3.25
- futures-macro-0.3.25
- futures-sink-0.3.25
- futures-task-0.3.25
- futures-util-0.3.25
- generic-array-0.14.6
- getrandom-0.1.16
- getrandom-0.2.8
- h2-0.3.15
- hashbrown-0.12.3
- hdrhistogram-7.5.2
- hermit-abi-0.1.19
- hermit-abi-0.2.6
- hex-0.4.3
- hmac-0.12.1
- http-0.2.8
- http-body-0.4.5
- http-range-header-0.3.0
- httparse-1.8.0
- httpdate-1.0.2
- humantime-2.1.0
- hyper-0.14.23
- hyper-timeout-0.4.1
- indexmap-1.9.2
- indoc-1.0.8
- inout-0.1.3
- ip_network-0.4.1
- ip_network_table-0.2.0
- ip_network_table-deps-treebitmap-0.5.0
- itertools-0.10.5
- itoa-1.0.5
- js-sys-0.3.60
- lazy_static-1.4.0
- libc-0.2.139
- lock_api-0.4.9
- log-0.4.17
- managed-0.8.0
- matchers-0.1.0
- matchit-0.7.0
- memchr-2.5.0
- memoffset-0.6.5
- mime-0.3.16
- minimal-lexical-0.2.1
- miniz_oxide-0.6.2
- mio-0.8.5
- nix-0.24.3
- nom-7.1.2
- num-traits-0.2.15
- num_cpus-1.15.0
- once_cell-1.17.0
- opaque-debug-0.3.0
- parking_lot-0.12.1
- parking_lot_core-0.9.6
- percent-encoding-2.2.0
- pin-project-1.0.12
- pin-project-internal-1.0.12
- pin-project-lite-0.2.9
- pin-utils-0.1.0
- poly1305-0.8.0
- ppv-lite86-0.2.17
- pretty-hex-0.3.0
- proc-macro2-1.0.49
- prost-0.11.6
- prost-derive-0.11.6
- prost-types-0.11.6
- pyo3-0.17.3
- pyo3-asyncio-0.17.0
- pyo3-build-config-0.17.3
- pyo3-ffi-0.17.3
- pyo3-log-0.7.0
- pyo3-macros-0.17.3
- pyo3-macros-backend-0.17.3
- quote-1.0.23
- rand-0.8.5
- rand_chacha-0.3.1
- rand_core-0.5.1
- rand_core-0.6.4
- redox_syscall-0.2.16
- regex-1.7.1
- regex-automata-0.1.10
- regex-syntax-0.6.28
- ring-0.16.20
- rustversion-1.0.11
- ryu-1.0.12
- scopeguard-1.1.0
- serde-1.0.152
- serde_derive-1.0.152
- serde_json-1.0.91
- sharded-slab-0.1.4
- signal-hook-registry-1.4.0
- slab-0.4.7
- smallvec-1.10.0
- smoltcp-0.8.2
- socket2-0.4.7
- spin-0.5.2
- subtle-2.4.1
- syn-1.0.107
- sync_wrapper-0.1.1
- synstructure-0.12.6
- target-lexicon-0.12.5
- termcolor-1.1.3
- thread_local-1.1.4
- tokio-1.24.1
- tokio-io-timeout-1.2.0
- tokio-macros-1.8.2
- tokio-stream-0.1.11
- tokio-util-0.7.4
- tonic-0.8.3
- tower-0.4.13
- tower-http-0.3.5
- tower-layer-0.3.2
- tower-service-0.3.2
- tracing-0.1.37
- tracing-attributes-0.1.23
- tracing-core-0.1.30
- tracing-futures-0.2.5
- tracing-subscriber-0.3.16
- try-lock-0.2.4
- typenum-1.16.0
- unicode-ident-1.0.6
- unicode-xid-0.2.4
- unindent-0.1.11
- universal-hash-0.5.0
- untrusted-0.7.1
- untrusted-0.9.0
- valuable-0.1.0
- version_check-0.9.4
- want-0.3.0
- wasi-0.9.0+wasi-snapshot-preview1
- wasi-0.11.0+wasi-snapshot-preview1
- wasm-bindgen-0.2.83
- wasm-bindgen-backend-0.2.83
- wasm-bindgen-macro-0.2.83
- wasm-bindgen-macro-support-0.2.83
- wasm-bindgen-shared-0.2.83
- web-sys-0.3.60
- winapi-0.3.9
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-util-0.1.5
- winapi-x86_64-pc-windows-gnu-0.4.0
- windows-sys-0.42.0
- windows_aarch64_gnullvm-0.42.0
- windows_aarch64_msvc-0.42.0
- windows_i686_gnu-0.42.0
- windows_i686_msvc-0.42.0
- windows_x86_64_gnu-0.42.0
- windows_x86_64_gnullvm-0.42.0
- windows_x86_64_msvc-0.42.0
- x25519-dalek-2.0.0-pre.1
- zeroize-1.5.7
- zeroize_derive-1.3.3
+ adler@1.0.2
+ aead@0.5.1
+ aho-corasick@0.7.20
+ anyhow@1.0.68
+ arc-swap@1.6.0
+ async-stream-impl@0.3.3
+ async-stream@0.3.3
+ async-trait@0.1.61
+ atty@0.2.14
+ autocfg@1.1.0
+ axum-core@0.3.1
+ axum@0.6.2
+ base64@0.13.1
+ bitflags@1.3.2
+ blake2@0.10.6
+ block-buffer@0.10.3
+ boringtun@0.5.2
+ bumpalo@3.11.1
+ byteorder@1.4.3
+ bytes@1.3.0
+ cc@1.0.78
+ cfg-if@1.0.0
+ chacha20@0.9.0
+ chacha20poly1305@0.10.1
+ cipher@0.4.3
+ console-api@0.4.0
+ console-subscriber@0.1.8
+ cpufeatures@0.2.5
+ crc32fast@1.3.2
+ crossbeam-channel@0.5.6
+ crossbeam-utils@0.8.14
+ crypto-common@0.1.6
+ curve25519-dalek@3.2.0
+ digest@0.10.6
+ digest@0.9.0
+ either@1.8.0
+ env_logger@0.9.3
+ flate2@1.0.25
+ fnv@1.0.7
+ futures-channel@0.3.25
+ futures-core@0.3.25
+ futures-executor@0.3.25
+ futures-io@0.3.25
+ futures-macro@0.3.25
+ futures-sink@0.3.25
+ futures-task@0.3.25
+ futures-util@0.3.25
+ futures@0.3.25
+ generic-array@0.14.6
+ getrandom@0.1.16
+ getrandom@0.2.8
+ h2@0.3.15
+ hashbrown@0.12.3
+ hdrhistogram@7.5.2
+ hermit-abi@0.1.19
+ hermit-abi@0.2.6
+ hex@0.4.3
+ hmac@0.12.1
+ http-body@0.4.5
+ http-range-header@0.3.0
+ http@0.2.8
+ httparse@1.8.0
+ httpdate@1.0.2
+ humantime@2.1.0
+ hyper-timeout@0.4.1
+ hyper@0.14.23
+ indexmap@1.9.2
+ indoc@1.0.8
+ inout@0.1.3
+ ip_network@0.4.1
+ ip_network_table-deps-treebitmap@0.5.0
+ ip_network_table@0.2.0
+ itertools@0.10.5
+ itoa@1.0.5
+ js-sys@0.3.60
+ lazy_static@1.4.0
+ libc@0.2.139
+ lock_api@0.4.9
+ log@0.4.17
+ managed@0.8.0
+ matchers@0.1.0
+ matchit@0.7.0
+ memchr@2.5.0
+ memoffset@0.6.5
+ mime@0.3.16
+ minimal-lexical@0.2.1
+ miniz_oxide@0.6.2
+ mio@0.8.5
+ nix@0.24.3
+ nom@7.1.2
+ num-traits@0.2.15
+ num_cpus@1.15.0
+ once_cell@1.17.0
+ opaque-debug@0.3.0
+ parking_lot@0.12.1
+ parking_lot_core@0.9.6
+ percent-encoding@2.2.0
+ pin-project-internal@1.0.12
+ pin-project-lite@0.2.9
+ pin-project@1.0.12
+ pin-utils@0.1.0
+ poly1305@0.8.0
+ ppv-lite86@0.2.17
+ pretty-hex@0.3.0
+ proc-macro2@1.0.49
+ prost-derive@0.11.6
+ prost-types@0.11.6
+ prost@0.11.6
+ pyo3-asyncio@0.17.0
+ pyo3-build-config@0.17.3
+ pyo3-ffi@0.17.3
+ pyo3-log@0.7.0
+ pyo3-macros-backend@0.17.3
+ pyo3-macros@0.17.3
+ pyo3@0.17.3
+ quote@1.0.23
+ rand@0.8.5
+ rand_chacha@0.3.1
+ rand_core@0.5.1
+ rand_core@0.6.4
+ redox_syscall@0.2.16
+ regex-automata@0.1.10
+ regex-syntax@0.6.28
+ regex@1.7.1
+ ring@0.16.20
+ rustversion@1.0.11
+ ryu@1.0.12
+ scopeguard@1.1.0
+ serde@1.0.152
+ serde_derive@1.0.152
+ serde_json@1.0.91
+ sharded-slab@0.1.4
+ signal-hook-registry@1.4.0
+ slab@0.4.7
+ smallvec@1.10.0
+ smoltcp@0.8.2
+ socket2@0.4.7
+ spin@0.5.2
+ subtle@2.4.1
+ syn@1.0.107
+ sync_wrapper@0.1.1
+ synstructure@0.12.6
+ target-lexicon@0.12.5
+ termcolor@1.1.3
+ thread_local@1.1.4
+ tokio-io-timeout@1.2.0
+ tokio-macros@1.8.2
+ tokio-stream@0.1.11
+ tokio-util@0.7.4
+ tokio@1.24.1
+ tonic@0.8.3
+ tower-http@0.3.5
+ tower-layer@0.3.2
+ tower-service@0.3.2
+ tower@0.4.13
+ tracing-attributes@0.1.23
+ tracing-core@0.1.30
+ tracing-futures@0.2.5
+ tracing-subscriber@0.3.16
+ tracing@0.1.37
+ try-lock@0.2.4
+ typenum@1.16.0
+ unicode-ident@1.0.6
+ unicode-xid@0.2.4
+ unindent@0.1.11
+ universal-hash@0.5.0
+ untrusted@0.7.1
+ untrusted@0.9.0
+ valuable@0.1.0
+ version_check@0.9.4
+ want@0.3.0
+ wasi@0.11.0+wasi-snapshot-preview1
+ wasi@0.9.0+wasi-snapshot-preview1
+ wasm-bindgen-backend@0.2.83
+ wasm-bindgen-macro-support@0.2.83
+ wasm-bindgen-macro@0.2.83
+ wasm-bindgen-shared@0.2.83
+ wasm-bindgen@0.2.83
+ web-sys@0.3.60
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-util@0.1.5
+ winapi-x86_64-pc-windows-gnu@0.4.0
+ winapi@0.3.9
+ windows-sys@0.42.0
+ windows_aarch64_gnullvm@0.42.0
+ windows_aarch64_msvc@0.42.0
+ windows_i686_gnu@0.42.0
+ windows_i686_msvc@0.42.0
+ windows_x86_64_gnu@0.42.0
+ windows_x86_64_gnullvm@0.42.0
+ windows_x86_64_msvc@0.42.0
+ x25519-dalek@2.0.0-pre.1
+ zeroize@1.5.7
+ zeroize_derive@1.3.3
"
inherit cargo distutils-r1
@@ -209,10 +210,15 @@ DESCRIPTION="WireGuard frontend for mitmproxy"
HOMEPAGE="https://github.com/decathorpe/mitmproxy_wireguard"
SRC_URI="
https://github.com/decathorpe/mitmproxy_wireguard/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
- $(cargo_crate_uris ${CRATES})
+ ${CARGO_CRATE_URIS}
"
-LICENSE="Apache-2.0 BSD BSD-2 ISC MIT Unlicense"
+LICENSE="MIT"
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ Unicode-DFS-2016
+"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~x86"