summaryrefslogtreecommitdiff
path: root/dev-python/mistune
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/mistune
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/mistune')
-rw-r--r--dev-python/mistune/Manifest5
-rw-r--r--dev-python/mistune/metadata.xml12
-rw-r--r--dev-python/mistune/mistune-0.7.2.ebuild28
-rw-r--r--dev-python/mistune/mistune-0.7.4.ebuild28
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/mistune/Manifest b/dev-python/mistune/Manifest
new file mode 100644
index 000000000000..d7a1250a16ca
--- /dev/null
+++ b/dev-python/mistune/Manifest
@@ -0,0 +1,5 @@
+DIST mistune-0.7.2.tar.gz 48887 BLAKE2B 4ff0286483e593fcf5183bfed18b90c39b93dacdec3bba474d6959ec1da162dd75820707a8ed9985fff4c15fe88a12df6fb6af20b9a40de173acd7c0a6e02893 SHA512 9002bf83a368671389f05928f4f689064a1e415e54309259b6bbb7781b4bfddbbf834e2c63ed3271e1e6ec7b78c1665c7708177b9723433d1e2ad4b13ad903ca
+DIST mistune-0.7.4.tar.gz 49304 BLAKE2B 9426007f618e645832d4d73db29cdda63e8426c9e52bda06935b0003b3c4f0122b14ca893ef4adad96c7d2f4b8be777efb6862f5370bdb9b08394129fd22e7d0 SHA512 d300bec23f5482396c6f282ee3d773461c162791e4605ca40141eb9487c8b158ac7f47f6338f7c3bf27bc614292ecc61dfbf419d47eab817821f18cf80103802
+EBUILD mistune-0.7.2.ebuild 713 BLAKE2B 7abb083a85460c32d7afef94ebef618546a519d842723c849ac77d8a8e61a66d94d677e1d5420052877e71beb4686b6c3295ec54282962125c624a10290161df SHA512 0dcf967246ab78ddff86fc8421cee3aa2cbfdd43a95c62d0495e18af00bf769978d9fea7dcd2cefc4ab1eaca58cd94d6891a085c0d1f445b225274df6a78f5f8
+EBUILD mistune-0.7.4.ebuild 732 BLAKE2B 973c19251996b630a47bdb74eee5a35c3d6f0b6aa412a15d96366d025f6b5117c788668c62412751d2095b273cd2e7af26a683cf28e66cea77404298623c667e SHA512 d8eb181163d8e2aa7e1634f163deeef9e77caa395ba9ceef983e429efbb0731c13acb3f044aa76a462a8b7f74c45ce4d43cfe61702e8bc5e822c3cd4d366742e
+MISC metadata.xml 377 BLAKE2B 6c495d3d88811994e4baf0aabb5267343c09162239cc655b5fe4f9b8b63df4cb08dff0186cbe6b63018eac2cc2489a3f612f72d49885df3055591da74f5fa5a5 SHA512 3630e9ba514f3f3b1ecf532ca928c3bc89c05ab50a9113ab4b1d609edf07a6421796774ee4a71cf17ea3c2939acea24e22a74f33b66fe630706dcd6482cf817e
diff --git a/dev-python/mistune/metadata.xml b/dev-python/mistune/metadata.xml
new file mode 100644
index 000000000000..f012a7616c68
--- /dev/null
+++ b/dev-python/mistune/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">mistune</remote-id>
+ <remote-id type="github">lepture/mistune</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mistune/mistune-0.7.2.ebuild b/dev-python/mistune/mistune-0.7.2.ebuild
new file mode 100644
index 000000000000..4e44d3a572bf
--- /dev/null
+++ b/dev-python/mistune/mistune-0.7.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.org/project/mistune/ https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/cython[$(python_gen_usedep 'python*')]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/mistune/mistune-0.7.4.ebuild b/dev-python/mistune/mistune-0.7.4.ebuild
new file mode 100644
index 000000000000..fc1aca516b8b
--- /dev/null
+++ b/dev-python/mistune/mistune-0.7.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.org/project/mistune/ https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/cython[$(python_gen_usedep 'python*')]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests || die
+}