summaryrefslogtreecommitdiff
path: root/dev-python/meteor-ejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/meteor-ejson
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/meteor-ejson')
-rw-r--r--dev-python/meteor-ejson/Manifest3
-rw-r--r--dev-python/meteor-ejson/metadata.xml17
-rw-r--r--dev-python/meteor-ejson/meteor-ejson-1.1.0.ebuild24
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/meteor-ejson/Manifest b/dev-python/meteor-ejson/Manifest
new file mode 100644
index 000000000000..ef6f46049979
--- /dev/null
+++ b/dev-python/meteor-ejson/Manifest
@@ -0,0 +1,3 @@
+DIST meteor-ejson-1.1.0.tar.gz 2292 BLAKE2B af832f42d53c27e3b9168c1f97bf807d6ba9967acdf41ec3ec32a77dae948c4befdcfac3a85f18a38b2c9efab6ff3a4b346931d48b30bec84b935be740764f1d SHA512 eb211d262f0006f3229296b71320f68b59d8a7e618e65baa8e613f874a0e6ac9cfe45e30fc73ba57c42129204c5f27a32c4b8b579527fcefd601fa1dc2844da3
+EBUILD meteor-ejson-1.1.0.ebuild 619 BLAKE2B a5c65fb4e138fff353a5d7ee0019ea4a326419dc6f4899e578a965256352c5f997942fc495020d96a4ec1077007e611ea1203c3f7f924905f0d29b56ee306d4d SHA512 21afe3f102268359d2a93dbe4f441d6782a609903cf96ea5685ac4e3d244900ad9aa6ef81f87a19689f610a9f2fd376c2b6187bdd76ef62d480fdb18e3ba877e
+MISC metadata.xml 592 BLAKE2B 21de6f8fed82161290a6541ede36e22155d0b12df84c8d9cee1018a2477fe86bc2335dfe5694ccbdc2cfdd7f2b3f6ae37b4f5ff53f624184ec5493a07d3585ad SHA512 9244b588bb294281d3542c6b868359369ee2ea1aabaa1765c2b768b8add49213bd705075082168ebec080619ca481650f7546fe6e1c9ffa68f08e2aef66cc936
diff --git a/dev-python/meteor-ejson/metadata.xml b/dev-python/meteor-ejson/metadata.xml
new file mode 100644
index 000000000000..6ded22bf29f4
--- /dev/null
+++ b/dev-python/meteor-ejson/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">meteor-ejson</remote-id>
+ <remote-id type="github">lyschoening/meteor-ejson-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/meteor-ejson/meteor-ejson-1.1.0.ebuild b/dev-python/meteor-ejson/meteor-ejson-1.1.0.ebuild
new file mode 100644
index 000000000000..56be8ba7d236
--- /dev/null
+++ b/dev-python/meteor-ejson/meteor-ejson-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Encoder and Decoder for Extended JSON (EJSON) as used in Meteor and DDP"
+HOMEPAGE="https://pypi.org/project/meteor-ejson/ https://github.com/lyschoening/meteor-ejson-python"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die
+}