summaryrefslogtreecommitdiff
path: root/dev-python/meson-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-22 01:05:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-22 01:05:27 +0000
commitb7819d03d7312d3d8d12b49738aa417f35f6e18a (patch)
treeddda281c46717f76e2c0d0ea4ed00da4bd58d9b5 /dev-python/meson-python
parent77b9f0d5906f0bd9ddf010abe155218c6629738a (diff)
gentoo auto-resync : 22:11:2022 - 01:05:27
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest3
-rw-r--r--dev-python/meson-python/files/meson-python-0.11.0-defaults.patch14
-rw-r--r--dev-python/meson-python/meson-python-0.11.0.ebuild71
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index cd2382544874..8c28ebc98ad4 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,4 +1,7 @@
+AUX meson-python-0.11.0-defaults.patch 608 BLAKE2B b4c8d87a766495ee644830dd98903e512e052ccb0c31b75ef755b2b33cc7b912ea3b232b66c539ec3da8d8d77ae90b04a87cac8d0c55cde4c00c0f32ca4cb001 SHA512 f814d2c93bdb14e245b83eb4a94329875ccaed2f9a78fb31ae5c5bc5b778bd25b22b097bbc5dbd810029b9613a2532d1ab971c8bb6c60cda41ad6d1351c9e93a
AUX meson-python-0.7.0-defaults.patch 506 BLAKE2B 404c8d4803f4e6ca5244dc27c84f2c0440999e3fff87febeb12d1d304c7ed9f9358f6b958b5975d171995960bbf7681003180765d2bdb88e694e52c518a8381d SHA512 43b9825b9facdcf72f0b4b80a72aac8544ec1cedb14a79c53dbe37b190af170584acbb0d281d89ddeb199ea5ba720eb0de04c5294a3e7197019c58d7ee14d786
DIST meson-python-0.10.0.gh.tar.gz 37739 BLAKE2B 028cbb191076b49946576b02d26a84079f412a178d9829bf85d579b8d3624e192e9394ade31524faf972ef4d105b7bf703e750529a7fafcbadf9a52d3c4876c6 SHA512 50d4d0bbf810948b4f218f25815058778b2a3ac8ff811d4d7cc699d1cfbcb75612d28789080b4e5ec3a47be03636389b7bf313366273abb733f77644758747cb
+DIST meson-python-0.11.0.gh.tar.gz 43192 BLAKE2B c12a18698f270b36685bbd4ad7ff5f2a718bab28f834cad89be724457704cd56966247e13ed6ba7dd201c5397ccfc78ab9202e7435f0672d63d544f67323b7b3 SHA512 fb894d0db6d18febd6388b7e686d0c7c1e3308f6ebf926c7300e2f376b1d2a803adcf5925c80d05982805e3ce4a59676c9ef829eacdab4696dabec3cb93e4192
EBUILD meson-python-0.10.0-r1.ebuild 1250 BLAKE2B d200020586a228b89b4f293cb5abedee3d3aabe71ae0c7d5aeefe9d19324b1f217639c3040d48914d2358a2bebaba66f60528b7fd06f0219970678a470a06e35 SHA512 b34dbe82facdde5b16ba1cfacaf2f985703fb49bf92a95641a8836b91163a6dece58ffc921aff52d3c163c36b0b7afd1a085ccaecb912ea208ee17f182355a5f
+EBUILD meson-python-0.11.0.ebuild 1567 BLAKE2B 540a9a3eab28c639682dcba295cc42dd18d836bb75e6269d3b7f944b58e55889e7d08a991b7c9fefe6e7eb1493e060e4ea87780ea5910501f634151c08277bff SHA512 21c7e0e7987f47b3ca7a0e20f5b1e9cbd1ee1e9b20a299fa26cfc1579419f4583984a6d7a41c4550b14e86d54754b0d6315598eba98bbed08e7dde828c6dd27d
MISC metadata.xml 357 BLAKE2B c2b5fd8c6ad39e92970a5e6c1db8950b4850660c9a95a84063504ab75e5dd69e3ab844fcef23cb51f33493b7e522a6d26227ff48dd893c92c422badc70f3c962 SHA512 1402ace4da543de7320a1d97f44177593807d5be9f1891d8a53190581877569508c46fe6b4ce63516c7fee2d2165d59d39f44343dde18438570883da3f4ad28c
diff --git a/dev-python/meson-python/files/meson-python-0.11.0-defaults.patch b/dev-python/meson-python/files/meson-python-0.11.0-defaults.patch
new file mode 100644
index 000000000000..6bd63f6d132e
--- /dev/null
+++ b/dev-python/meson-python/files/meson-python-0.11.0-defaults.patch
@@ -0,0 +1,14 @@
+See https://github.com/mesonbuild/meson-python/blob/main/mesonpy/__init__.py#L452.
+
+(Also: https://github.com/mesonbuild/meson-python/issues/54)
+--- a/mesonpy/__init__.py
++++ b/mesonpy/__init__.py
+@@ -734,7 +734,7 @@ class Project():
+ @functools.lru_cache(maxsize=None)
+ def build(self) -> None:
+ """Trigger the Meson build."""
+- self._meson('compile', *self._meson_args['compile'],)
++ self._meson('compile', '--verbose', *self._meson_args['compile'],)
+ self._meson('install', '--destdir', os.fspath(self._install_dir), *self._meson_args['install'],)
+
+ @classmethod
diff --git a/dev-python/meson-python/meson-python-0.11.0.ebuild b/dev-python/meson-python/meson-python-0.11.0.ebuild
new file mode 100644
index 000000000000..5cac128d62ea
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.11.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/mesonbuild/meson-python/
+"
+SRC_URI="
+ https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.6.1[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.0-defaults.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+)
+
+src_prepare() {
+ # strip dependency on ninja -- we provide ninja via Gentoo package
+ # rather than the Python wheel, so we don't have .dist-info there
+ sed -i -e '/ninja/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+ )
+
+ epytest
+
+ rm -rf docs/examples/spam/build/ || die # remove artifacts
+}