summaryrefslogtreecommitdiff
path: root/dev-python/meson-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
commit1ffbeeb1643e9197d8a58c65a1d76bbaf3656292 (patch)
tree2cb5d912afaf290c355b58f8a7334b0e6c5277f0 /dev-python/meson-python
parent7819ef4baadbb9171070ce385f7051989fe64e49 (diff)
gentoo auto-resync : 23:12:2022 - 13:59:28
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest2
-rw-r--r--dev-python/meson-python/meson-python-0.12.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 28184fbd7491..f3b3dcd9ba4f 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,4 +1,6 @@
AUX meson-python-0.11.0-defaults.patch 608 BLAKE2B b4c8d87a766495ee644830dd98903e512e052ccb0c31b75ef755b2b33cc7b912ea3b232b66c539ec3da8d8d77ae90b04a87cac8d0c55cde4c00c0f32ca4cb001 SHA512 f814d2c93bdb14e245b83eb4a94329875ccaed2f9a78fb31ae5c5bc5b778bd25b22b097bbc5dbd810029b9613a2532d1ab971c8bb6c60cda41ad6d1351c9e93a
DIST meson-python-0.11.0.gh.tar.gz 43192 BLAKE2B c12a18698f270b36685bbd4ad7ff5f2a718bab28f834cad89be724457704cd56966247e13ed6ba7dd201c5397ccfc78ab9202e7435f0672d63d544f67323b7b3 SHA512 fb894d0db6d18febd6388b7e686d0c7c1e3308f6ebf926c7300e2f376b1d2a803adcf5925c80d05982805e3ce4a59676c9ef829eacdab4696dabec3cb93e4192
+DIST meson-python-0.12.0.gh.tar.gz 43801 BLAKE2B fa4f5b73d490fce64da5c9f79c590e32af5b39790c0ffddc694a6b11a9274760a4e92a3d45abdefdbec1e6c5235ae799ee6c3e1b99685028b3bc007d5322683d SHA512 f2e416027bb6fb6cf6ad0fd84c6b65ddc83b497ff96b5a144dfcdd1addee44972eaa7422c8d9a8092431b6df1b052f970e9e7bd7dc57b28fbf42d2ea3a8d9231
EBUILD meson-python-0.11.0.ebuild 1568 BLAKE2B 8282a7aa892197a9d97802224f83aa3801ba3dc56c47f6c3058e2f2ab8f637ec59c106699cb50b4bba9f02c75225887727d431ac7b7c4352234e4dbdd8b84fc1 SHA512 9527ef2c30f14bf6fc5f4b9274489c34a6eaf800754474db1b1457a08370b4fd240d728d994d438ee77a3e451dcb09967bf4fdd6e1c0b15c7a06c7aedbcad101
+EBUILD meson-python-0.12.0.ebuild 1660 BLAKE2B e122c6f29a497e620b9707b52ffcd768694fef162588efe154bce9d8d75afd55e94e40c0796a3486ca8bbb519183dd0d4f8e4e4475ca149d46450b7973468bec SHA512 54813c5c7eb3e90f38a4f601379dc47eb1a5edf50282c73810e9bbf2167c16cd2f064f1191123f2bd9d236646c19637b835d334ee1840a69cddb913af84cf67b
MISC metadata.xml 357 BLAKE2B c2b5fd8c6ad39e92970a5e6c1db8950b4850660c9a95a84063504ab75e5dd69e3ab844fcef23cb51f33493b7e522a6d26227ff48dd893c92c422badc70f3c962 SHA512 1402ace4da543de7320a1d97f44177593807d5be9f1891d8a53190581877569508c46fe6b4ce63516c7fee2d2165d59d39f44343dde18438570883da3f4ad28c
diff --git a/dev-python/meson-python/meson-python-0.12.0.ebuild b/dev-python/meson-python/meson-python-0.12.0.ebuild
new file mode 100644
index 000000000000..54415126ce33
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.12.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/mesonbuild/meson-python/
+"
+SRC_URI="
+ https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.6.1[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.0-defaults.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+)
+
+src_prepare() {
+ # strip dependency on ninja -- we provide ninja via Gentoo package
+ # rather than the Python wheel, so we don't have .dist-info there
+ sed -i -e '/ninja/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+ )
+
+ epytest
+
+ rm -rf docs/examples/spam/build/ || die # remove artifacts
+}