summaryrefslogtreecommitdiff
path: root/dev-python/meshio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-19 00:30:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-19 00:30:04 +0000
commit781c9128468d2e8302221d4d7152ae09cffc4a9e (patch)
tree1f0892c391dbb3e56d61a206fdc800034917eead /dev-python/meshio
parentcade0827f4ab3a7b13c870b7841c4462dde54dc6 (diff)
gentoo auto-resync : 19:03:2025 - 00:30:03
Diffstat (limited to 'dev-python/meshio')
-rw-r--r--dev-python/meshio/Manifest3
-rw-r--r--dev-python/meshio/files/meshio-5.3.5-numpy-2.patch52
-rw-r--r--dev-python/meshio/meshio-5.3.5-r1.ebuild (renamed from dev-python/meshio/meshio-5.3.5.ebuild)9
3 files changed, 61 insertions, 3 deletions
diff --git a/dev-python/meshio/Manifest b/dev-python/meshio/Manifest
index cebc7c247c77..bee9fee3d53b 100644
--- a/dev-python/meshio/Manifest
+++ b/dev-python/meshio/Manifest
@@ -1,3 +1,4 @@
+AUX meshio-5.3.5-numpy-2.patch 2031 BLAKE2B 01608f6634b54a8767d3c8d8c289e6662ab662f8e5663fc194b1d29be0d229dedd407e0f0869c8580abf4495357e67d6e116b8dff7d6400485690feb655e669b SHA512 6877691aefc053e6b5d284c21f07c7a1ac29becc3564d5fa9e623ef0e865311097bee0e7fce475b737104d97c0ba6cdf478c61810d94b60940e9a304809a0fae
DIST meshio-5.3.5.tar.gz 490922 BLAKE2B ff6635db062b5e4041d7a4389f1e2fefc20cf55c1c0e70be1796c9e65e87daf503c7446224130eee94a3a2d0fb52dcd57ce3fa169afe7ca7fe32c3037fa21e00 SHA512 dcf6b914536b5b109ead378b7314de8f6f65ca7eb9b8c1092ce51308c32175c92a8f6386087b00770cd64eddcbc3fa80232dd30b370880894c0fa0b074bd7313
-EBUILD meshio-5.3.5.ebuild 684 BLAKE2B bdddf8eaecbe4a7f75069cba830427cf75487f97eefc1aa475eca78f67315af85d480aee22067f435cbbafa1fc539b3d4e3e65b8ef37e6908fde9c0925b46257 SHA512 206f798f5a15d06dd86b1a4c16bfd6188d184f34cdef2519c1783d36a79f32bfab72caf2201626ddb6155d6fb3898d99afaeed51ffd5c659bef0e4cd6f7f3850
+EBUILD meshio-5.3.5-r1.ebuild 778 BLAKE2B ceba5b84edef762afc4be8eddfe86f4220bc37288a1189e460a71cf43cfbde35eab657392abca2f1a83946a22c48069a8ebfdbbfd02d4d2998741f15a413a50a SHA512 9d9b31c71968ebf2353f0b7aa09d162b27eb25ed9359fc3467be32b16f2c3a28f8bd6616f999a3424a305d66abb78bd0cc1656620a4ceb52922264c63e097a40
MISC metadata.xml 388 BLAKE2B 3fcedf4e5502bf7d117a8ad654b2639d497ce093eadca30fe2d0084574cb772d8aa4c5b0b5dd5400340fdd8aa081f9cbfd2ec61b1e36e60d1ccbe46a0128cd18 SHA512 73d3857688eea884233ef05adc4a9e496e51008710d900243d5699a36b37b1025c95afec2f29c043fe20dd26c8af7a2cc79c011539fd60c4ffadd5d80666fdf3
diff --git a/dev-python/meshio/files/meshio-5.3.5-numpy-2.patch b/dev-python/meshio/files/meshio-5.3.5-numpy-2.patch
new file mode 100644
index 000000000000..dc7662c3042f
--- /dev/null
+++ b/dev-python/meshio/files/meshio-5.3.5-numpy-2.patch
@@ -0,0 +1,52 @@
+diff --git a/src/meshio/dolfin/_dolfin.py b/src/meshio/dolfin/_dolfin.py
+index e43dbd54..0a2c1eaa 100644
+--- a/src/meshio/dolfin/_dolfin.py
++++ b/src/meshio/dolfin/_dolfin.py
+@@ -207,7 +207,7 @@ def _write_cell_data(filename, dim, cell_data):
+ )
+
+ for k, value in enumerate(cell_data):
+- ET.SubElement(mesh_function, "entity", index=str(k), value=repr(value))
++ ET.SubElement(mesh_function, "entity", index=str(k), value=str(value))
+
+ tree = ET.ElementTree(dolfin)
+ tree.write(filename)
+diff --git a/src/meshio/gmsh/common.py b/src/meshio/gmsh/common.py
+index 717e82ee..adcae241 100644
+--- a/src/meshio/gmsh/common.py
++++ b/src/meshio/gmsh/common.py
+@@ -273,7 +273,7 @@ def _write_data(fh, tag, name, data, binary):
+ tmp.tofile(fh)
+ fh.write(b"\n")
+ else:
+- fmt = " ".join(["{}"] + ["{!r}"] * num_components) + "\n"
++ fmt = " ".join(["{}"] * (num_components + 1)) + "\n"
+ # TODO unify
+ if num_components == 1:
+ for k, x in enumerate(data):
+diff --git a/src/meshio/mdpa/_mdpa.py b/src/meshio/mdpa/_mdpa.py
+index afa39eca..e49358af 100644
+--- a/src/meshio/mdpa/_mdpa.py
++++ b/src/meshio/mdpa/_mdpa.py
+@@ -418,7 +418,7 @@ def _write_data(fh, tag, name, data, binary):
+ data = data[:, 0]
+
+ # Actually write the data
+- fmt = " ".join(["{}"] + ["{!r}"] * num_components) + "\n"
++ fmt = " ".join(["{}"] * (num_components + 1)) + "\n"
+ # TODO unify
+ if num_components == 1:
+ for k, x in enumerate(data):
+diff --git a/src/meshio/ugrid/_ugrid.py b/src/meshio/ugrid/_ugrid.py
+index 6fa57c09..f1d5818d 100644
+--- a/src/meshio/ugrid/_ugrid.py
++++ b/src/meshio/ugrid/_ugrid.py
+@@ -145,7 +145,7 @@ def read_buffer(f, file_type):
+ def _write_section(f, file_type, array, dtype):
+ if file_type["type"] == "ascii":
+ ncols = array.shape[1]
+- fmt = " ".join(["%r"] * ncols)
++ fmt = " ".join(["%s"] * ncols)
+ np.savetxt(f, array, fmt=fmt)
+ else:
+ array.astype(dtype).tofile(f)
diff --git a/dev-python/meshio/meshio-5.3.5.ebuild b/dev-python/meshio/meshio-5.3.5-r1.ebuild
index 8bb43bf2183b..5a1ea9faf150 100644
--- a/dev-python/meshio/meshio-5.3.5.ebuild
+++ b/dev-python/meshio/meshio-5.3.5-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
@@ -30,3 +30,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/nschloe/meshio/pull/1513
+ "${FILESDIR}/${P}-numpy-2.patch"
+)