summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
commit693cc9b6e847a01c1bb692153021aaf9fb0fab25 (patch)
treebb2f7c299a4149f841c37a1208c7ac861aa95640 /dev-python/memory_profiler
parent09351e78166b5e864197c4456ebae3f89dd0bed9 (diff)
gentoo resync : 25.01.2019
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest2
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.55.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index e2fa7435c116..6643245ace6f 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1,5 +1,7 @@
DIST memory_profiler-0.47.tar.gz 33725 BLAKE2B 66fc0e5c579febeea9dcd5132caa6fdbccdb5cb0a2c9083f5abf8aa03baaaafe1f77f72cdbe4d5384c6ce27fd4760511f9a947fda46eee1d81e7125c1dcd2970 SHA512 110e16ecad33068d31cf53b2f0b775d65230d51345f24a4d7d3cafafb706b10a0c7e2d98a799256b0366f1bafa9b69c060222595bb4eb9e1689301428a36fc3d
DIST memory_profiler-0.54.0.tar.gz 31376 BLAKE2B 4c89a046bdce36a139448dde45c8cf952aaa8fe8e2089bf9574a8fb2ed1abb89991e54f59742b0ea1ae5315378c0799ef140752549f9a8d13a91bf0ceb021984 SHA512 ec5735b7e41e706ea35ce9fe0dd3963c51e50e5bdf7f1871c51bbbb2a0ae75abcdba23abd3a14979c26ce19e7ce7d2cf6782aefc77e0c17cfe4da573a6e249ae
+DIST memory_profiler-0.55.0.tar.gz 40951 BLAKE2B ed6eefa0a522eaddfd0ebf3b118a57b7bcf6c7455057d1a9e891e826ba2b32a671fd86357d073f45c36ae5db418987a55e90a908cbb4aba3b3f972ba4580f9f6 SHA512 9f280af163b124809d0276b2a473f66d9f11071f38afbabf7247d4e49f120c137f69dde2cc3fb27fcc88cfc6dc71355ba01efeb102098c401c7e953462ed4a1b
EBUILD memory_profiler-0.47.ebuild 1235 BLAKE2B 9a10cb80fb9381a1e01d323ac993f6345188dadcfbbaa5d5e44ea480bafb23443260e8c47dd14383c96c8060baf6c7ae3cc5eb8eff1fa39252c5b1915190b514 SHA512 aa3fe3d37492689b2b349c81e2e3a64d6fcf2aca4c0955ded24ae01b5eedce55f4dd9f7c5ec380e8e7362b53d0f1649806b5468637bb6f4c1640b9626ccfa4ba
EBUILD memory_profiler-0.54.0.ebuild 1316 BLAKE2B 2191ada8dd9febcd86b7a424c4bc2879b4ae89d109a67887d904ede8e3f79ce1db46b2f9f8fd62a26f722729362ad8487f57cc4c311f77e784478e81f432b348 SHA512 9b8bea1007c0095f460e10fa5e8980860e576402065fd2d93e231f6adb6d6b48da72ac198a886b7a1a10bb8e79263955fd13be50c78464854f63df96243fd794
+EBUILD memory_profiler-0.55.0.ebuild 1316 BLAKE2B a2039edcef14ff103928ac00ddbf506a98119d02b6632b7341d002ca1049076ebfa6bb330a103dd1771a23943c08fd781e53ca70d9d37f05cd52a37e4d7ff97f SHA512 5cc6374ca9fc005609b7715a04abbc9ad67be4d6c4d35d0e63d0211c71de2b1d587c6dc73630273402b04ecbbb53fe6fd85cc962dbc1fae81c440f59ba72de91
MISC metadata.xml 514 BLAKE2B 9721c8c8ab0f05e50b0d3d9fe16e0392aaa513177abdd4318aa2b10c70a656627e054b0a162eb7324e9b20e8f74dd1c3f3fbf4aa456fe98a34899525e3d9ad5a SHA512 cedc4d8914ad8cf10c8981935089220967957ff50eecfd867376974055d4922df91357a2f2135ce3cf5f56a27c5111005ae53429e685f0ee080e031bb2a3e943
diff --git a/dev-python/memory_profiler/memory_profiler-0.55.0.ebuild b/dev-python/memory_profiler/memory_profiler-0.55.0.ebuild
new file mode 100644
index 000000000000..c3b690f74c10
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.55.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="https://pypi.org/project/memory_profiler/ https://github.com/fabianp/memory_profiler"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# dev-lang/mercury: collision on 'mprof'
+# https://bugs.gentoo.org/571176
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ !dev-lang/mercury
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_global.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} -m memory_profiler test/test_gen.py || die
+ if python_is_python3; then
+ ${EPYTHON} -m memory_profiler test/test_unicode.py || die
+ fi
+ ${EPYTHON} test/test_tracemalloc.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+}