summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/memory_profiler
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest4
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.43.ebuild39
-rw-r--r--dev-python/memory_profiler/metadata.xml16
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
new file mode 100644
index 000000000000..bc53aefa475a
--- /dev/null
+++ b/dev-python/memory_profiler/Manifest
@@ -0,0 +1,4 @@
+DIST memory_profiler-0.43.tar.gz 31496 SHA256 ee2d4fb8f95b90d6faa511e46f4d117d4f17f7c62bb081f7266e9c98c23aeba4 SHA512 6c0bbece0b2a7da5504e878db3777ae86009ed3730a00527af457e4c216e7f5423feee79216bf28496374a2a597fd0cc2b267a312587ed01ac42f6ec3351eca6 WHIRLPOOL e0ac0eb1a99463fe295277768c4c97f23e7bd70f34e9d8a32b115247baa4c51b3c639e86ae24e77602aa97a648d026b36afd1c35dfda63bd7e7759bf5aeddcea
+EBUILD memory_profiler-0.43.ebuild 1237 SHA256 37210e6956eafdc5569a31c7e9cc5d29196fdf6e118df2d4d485dd6d757d1da7 SHA512 491670ae51e9516440f1acc559dc3b9ceb1af97607af09c0dae57a3954c766a5f94b88c0724f6c3ab0412c3f289ce1ee2be7688b33e5adb9ebf8dcf0a17c0d5b WHIRLPOOL c6c62c537503b3601df386f4545ee046ddaa3d4f4d141291194d8f8667036eea1c478cfd5894273fea65607db82bac7d04e101cbff47479e8a580e45e532945c
+MISC ChangeLog 2147 SHA256 4046ccc95cc3a76a996b16bfab1ebfd8c0d941ae5a45bc707f908656ce3ad6c6 SHA512 db95d57e338664d7049e3f80b000af72624c6539898291ad0dad38522734d07d75bc2bc2807c111255b9edb7d3af1f4a631ce4e825c855791327017443c5aa6b WHIRLPOOL ace7f3816f1a2236d80592cfe993a21ad58a68772ff00debc56e851da7ff0197b30ce8408f17f1d8c645ce013bed50cc4581efefa3a8ea3945ec2f5d8b9c705b
+MISC metadata.xml 514 SHA256 4c47574a29b9890d139a148204df5ff72096441c205af77d5a5f96df68f71883 SHA512 cedc4d8914ad8cf10c8981935089220967957ff50eecfd867376974055d4922df91357a2f2135ce3cf5f56a27c5111005ae53429e685f0ee080e031bb2a3e943 WHIRLPOOL 0acfb21589da8b120fdb8ece38bc070dfa10fa22dafea840b772745e334d15e3258ba5f50ca0e5b60958d0da708b973cc37f12fec194cf6dfbf32895c513eac0
diff --git a/dev-python/memory_profiler/memory_profiler-0.43.ebuild b/dev-python/memory_profiler/memory_profiler-0.43.ebuild
new file mode 100644
index 000000000000..3c9eee9a0e51
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.43.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="http://pypi.python.org/pypi/memory_profiler https://github.com/fabianp/memory_profiler"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_global.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} -m memory_profiler test/test_gen.py || die
+ if python_is_python3; then
+ ${EPYTHON} -m memory_profiler test/test_unicode.py || die
+ fi
+ ${PYTHON} test/test_tracemalloc.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+}
diff --git a/dev-python/memory_profiler/metadata.xml b/dev-python/memory_profiler/metadata.xml
new file mode 100644
index 000000000000..73a90c01eacf
--- /dev/null
+++ b/dev-python/memory_profiler/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">memory_profiler</remote-id>
+ <maintainer status="unknown">
+ <email>f@bianp.net</email>
+ <name>Fabian Pedregosa</name>
+ </maintainer>
+ <remote-id type="github">fabianp/memory_profiler</remote-id>
+ </upstream>
+</pkgmetadata>