summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/memory_profiler/memory_profiler-0.58.0.ebuild')
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.58.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild b/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
deleted file mode 100644
index fb5f53ccb4a9..000000000000
--- a/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A module for monitoring memory usage of a python program"
-HOMEPAGE="https://pypi.org/project/memory_profiler/ https://github.com/pythonprofilers/memory_profiler"
-SRC_URI="
- https://github.com/pythonprofilers/memory_profiler/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-IUSE="examples"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-# dev-lang/mercury: collision on 'mprof'
-# https://bugs.gentoo.org/571176
-RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
- !dev-lang/mercury"
-
-distutils_enable_tests pytest
-
-python_test() {
- ${EPYTHON} -m memory_profiler test/test_as.py || die
- ${EPYTHON} -m memory_profiler test/test_func.py || die
- ${EPYTHON} -m memory_profiler test/test_gen.py || die
- ${EPYTHON} -m memory_profiler test/test_loop.py || die
- ${EPYTHON} -m memory_profiler test/test_loop_decorated.py || die
- ${EPYTHON} -m memory_profiler test/test_mprofile.py || die
- ${EPYTHON} -m memory_profiler test/test_nested.py || die
- ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
- ${EPYTHON} -m memory_profiler test/test_unicode.py || die
-
- ${EPYTHON} test/test_exception.py || die
- ${EPYTHON} test/test_exit_code.py || die
- ${EPYTHON} test/test_global.py || die
- ${EPYTHON} test/test_import.py || die
- ${EPYTHON} test/test_memory_usage.py || die
- ${EPYTHON} test/test_mprof.py || die
- ${EPYTHON} test/test_precision_import.py || die
- ${EPYTHON} test/test_stream_unicode.py || die
- ${EPYTHON} test/test_tracemalloc.py || die
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}