summaryrefslogtreecommitdiff
path: root/dev-python/memory-allocator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-25 07:01:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-25 07:01:01 +0000
commit50c71de793c37c19d34a68b3af53ba5e7ca51d22 (patch)
tree93bc7fabec8ef4fa120a75fa4dfefb65b839b92c /dev-python/memory-allocator
parent2808be9288546424bc5e88a39631a6835e6bd388 (diff)
gentoo auto-resync : 25:03:2024 - 07:01:01
Diffstat (limited to 'dev-python/memory-allocator')
-rw-r--r--dev-python/memory-allocator/Manifest2
-rw-r--r--dev-python/memory-allocator/memory-allocator-0.1.4.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/memory-allocator/Manifest b/dev-python/memory-allocator/Manifest
index 28e1c373e151..ff10342b2c21 100644
--- a/dev-python/memory-allocator/Manifest
+++ b/dev-python/memory-allocator/Manifest
@@ -1,3 +1,5 @@
DIST memory_allocator-0.1.3.tar.gz 19692 BLAKE2B e3e33b4d35455c7cf38eede4f8acfb5bddada59364de53c8ac37fc18e0824a947b85b4c6e3ce9b2f817948c6e83709c17cdf68fa3ebbe6b562d315420235f0cf SHA512 41cb850346b1aead18c82b0eca48791336315b5da8c2beeccec4eae90f55425f545a7cfd42c8cb9bd9f8c25a3a31b7334e304c0d726fdd848df26ae72ec7b7a7
+DIST memory_allocator-0.1.4.tar.gz 19723 BLAKE2B 22643aa32ac43f0e80e76b9d214c5decb70fbb83ddf4e116739bd257df1a2f2f02cf33c4a8925d0a38af2c59b90ee4fb6ccdfe2256fccae00ad98b2a9596e1db SHA512 0cd8b4d5878fa86972f9aa91e1fef4c074c3a0afe25ac1e54a3ad5e3b1ec5e4907cdd067d790f4e2ab7706f5dc2ff44c43ca0bc8e03b1b4dc90d66d8aa49ba0f
EBUILD memory-allocator-0.1.3.ebuild 985 BLAKE2B 78855057cc4daab2636d7ace6c8c196f467aad7279d7e6b480a98ecc0ca4c3769b5fa5b9ec242859a677dbb69d91f8f1cafe94a6ed98bd6a90b885c096fe03ad SHA512 cb9eccb853ad374e10f82353492b49c4971632ffd0b4e68d59d1720b465b119516acacf569bd5ea5cdff74a24e843b58e016420448686ed7e9ec3bdaa828e2ef
+EBUILD memory-allocator-0.1.4.ebuild 986 BLAKE2B c761cfff21916a9e70329404bfa9448c3e7dfb71f2877a3377fb1ebc0b1fa2f79bb16435c5dc6a56cb1570b8dd49bceb0c865ef2b87a8b03e3d9e1bd46d2aaa4 SHA512 70d7b40b9441fe717a1754c0a87f9a1b0ee950a48ce5bafd4996d11210c98cabc88a96cf3a59ad11e1abed5d7e29bc5033267ecdd90cd42cdd1462689c1bb3f0
MISC metadata.xml 1092 BLAKE2B 495f160cb60544af5d379c32016e61ecd451b174223c0c919c782180aa6474e9e2dce8150f43be5174e3d8a55cab492469f7aafb5d5cb19e469435d672fcb143 SHA512 7118041702e4cd3226632896df70032054dbbbc9aa985a51b83d513ff451b5123d8adb58c80f353dbdd0ee5d783dc378bb417bfc75b2dce935e2d15edc2e4c4e
diff --git a/dev-python/memory-allocator/memory-allocator-0.1.4.ebuild b/dev-python/memory-allocator/memory-allocator-0.1.4.ebuild
new file mode 100644
index 000000000000..82937d8dd032
--- /dev/null
+++ b/dev-python/memory-allocator/memory-allocator-0.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="An extension class for memory allocation in cython"
+HOMEPAGE="https://pypi.org/project/memory-allocator/
+ https://github.com/sagemath/memory_allocator"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+ # The test script tries to "import memory_allocator.test" which, so
+ # long as a memory_allocator directory exists inside CWD, will look
+ # for a memory_allocator/test.py there. But there is no such file;
+ # the "test" module is a compiled extension. To let the search fall
+ # back to the correct location, we temporarily rename the directory
+ # that misleads it.
+ mv memory_allocator mv_memory_allocator || die
+ ${EPYTHON} test.py || die
+ mv mv_memory_allocator memory_allocator || die
+}