summaryrefslogtreecommitdiff
path: root/dev-python/mdurl/mdurl-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/mdurl/mdurl-0.1.1.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/mdurl/mdurl-0.1.1.ebuild')
-rw-r--r--dev-python/mdurl/mdurl-0.1.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/mdurl/mdurl-0.1.1.ebuild b/dev-python/mdurl/mdurl-0.1.1.ebuild
new file mode 100644
index 000000000000..8b3d3875e037
--- /dev/null
+++ b/dev-python/mdurl/mdurl-0.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Markdown URL utilities"
+HOMEPAGE="
+ https://pypi.org/project/mdurl/
+ https://github.com/executablebooks/mdurl/
+"
+SRC_URI="
+ https://github.com/hukkin/mdurl/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest