summaryrefslogtreecommitdiff
path: root/dev-python/mdit-py-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 08:13:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 08:13:24 +0000
commitfd089c26c06476b291a5255011ee378561c2615d (patch)
tree399fe09e6963d1ae925dd682eabcc3fab873daf7 /dev-python/mdit-py-plugins
parent1aa99ecc93a15a428a88197dd05d97bcd33102b7 (diff)
gentoo auto-resync : 19:02:2023 - 08:13:24
Diffstat (limited to 'dev-python/mdit-py-plugins')
-rw-r--r--dev-python/mdit-py-plugins/Manifest2
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.3.4.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index 11f83afd490d..1909ffec81fc 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1,3 +1,5 @@
DIST mdit-py-plugins-0.3.3.gh.tar.gz 57366 BLAKE2B 60b53c6aa404a22296da122b6528491fa7dc52c4b485dea1b0c26c486cd04bf495948e03c40d54ac9d436431ab1154f51af90c84762f96d87984b74718a736a9 SHA512 a32a4a7004368af924c0876106e10a55a2f361a18db127a45080779bc39fb709ca274febbb4c4d5e872357e99bd8161e6c760783793516011da5f963368fa637
+DIST mdit-py-plugins-0.3.4.gh.tar.gz 59538 BLAKE2B 7046c2b8b5b117612a71c1a4894c7e3e49a161b5375fde13ec61c4a00c2bf5824505cb5639b70a3c58d7c9629e68bf794c950b5a28470392487965cd94f3e9a9 SHA512 e36b0ee0aca95d60c27a577e1c4bde9832d633ca84fb740f16a37dd63ece0a77005f8e3d03360ed0c92de57d3f656a8f76ab76642d8da3e5ac1d65384ee18d84
EBUILD mdit-py-plugins-0.3.3.ebuild 743 BLAKE2B 808462006e58a24015302df3a037075e497056d976b96cd5aeb9cb47630f6daa5b67f00dc79aceea3f0adc7dc48dfbbf9d6bc4238c22430be5791020bb4c1ccd SHA512 04d1abf207d4d145e2a90ee940a1b4b5242462df9820dc082ffc6a550173912f07a383e69be4a5d55de2943e864024c16346b3aa1cb14a98874f97a888ea9db9
+EBUILD mdit-py-plugins-0.3.4.ebuild 751 BLAKE2B 773735455d931ba1229aaf6157800b072c349f6d82e9ae2c5ed263d2f0606ac62ec611148223171e45fc4cc242f64368076a42907b08aee1df9582c3d480e83f SHA512 bbf9cec15554bee6cfbb9be6b6788b517026fa452f931e5e12e3382d7ea525a5fa80132f4625ced17ea7572877fdbb580a78b40a459f3969267c5eb309333ddd
MISC metadata.xml 414 BLAKE2B b7b6cfc3dff5ca097543d0541b066c466669ea3d9193e10530e97f6992053bedb67badf78023b14893d779a1580eb3bb385d51affc5a0927d76f89ddeed1be24 SHA512 564918fba45aa79a7a05d532691fe15aaa61a0e16e6004d57875720a26fc13548d37793fbab83479d0fc8c70764b3f919430a9bd698c03c85bf9103b56355166
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.4.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.4.ebuild
new file mode 100644
index 000000000000..9dcd74e0c13e
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest