summaryrefslogtreecommitdiff
path: root/dev-python/mdit-py-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
commit996d1cba721b044876526a7f3c1d2ef1fcc90bb4 (patch)
tree16fac72b3f131ad5671db34f88cd6426ff602706 /dev-python/mdit-py-plugins
parent0cfdfb9b75c154c98f3963d4a002425218e29efc (diff)
gentoo auto-resync : 06:06:2023 - 09:39:05
Diffstat (limited to 'dev-python/mdit-py-plugins')
-rw-r--r--dev-python/mdit-py-plugins/Manifest2
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.4.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index e2d0eb2bd57a..24a363937f2f 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1,3 +1,5 @@
DIST mdit-py-plugins-0.3.5.gh.tar.gz 59757 BLAKE2B bad78ec811d238bafd83c9d1bbd6e0bcac3b70cd87f52b215966e836d4c2a35715804fa1c7d3671de81713c4e169ad4bb6d9dcdf741f617544772d06f8e3ae56 SHA512 6cb153d8ccff8fa3f94731606ad5dd1c06954d95519ac77b6de477e04b878f84fb059052906bdea5d798be3de49733a909cb553107255a61cde6dd1c6c72d4d2
+DIST mdit-py-plugins-0.4.0.gh.tar.gz 62199 BLAKE2B d8e69022ecceed436cd28202406bd46e786d40d3527f1c2c9311c4c32c59a4806cde9dc386309976c185522dd6286aec2542dabd31e08b8d7322fd02ae07186d SHA512 cdcce7a3819120923b7725daae0bf7a833c4da4487c49ff1a067fecf7d5e8f7a7be2fae03f3b821c766d7d6ebed4a298755ad5edb00adf73300a76a5663d67d6
EBUILD mdit-py-plugins-0.3.5.ebuild 750 BLAKE2B c73456e500006d38b7a2bcd2c1b124363bcbca2dc5d2bd43240b1284e0bee4bc8e9fda4544a836c7121b299a914dd9744ccc515358021f63048ffbbe3606a4a1 SHA512 b5365f6aeb93e6bd3b5391c4e7f9a9cfdbfbfa172da0ecef12955859f0921fd84dc3a5f12126d52304b7787e99806e1ef7857b4f6cadf8ad23b2ce2c57291176
+EBUILD mdit-py-plugins-0.4.0.ebuild 761 BLAKE2B e0bcede0975c1b36f301138ae65cf91caba35039688cb8a397c3a527bcaf6be83367952f027164e27fecaec80bd85d27dec69bd82d29d6a9e828c2efe7209cc9 SHA512 e56fc4441391c48f3e22e7b93dcfb48ab4205496b4f545ce7f34db47b5f70b18447328e8bc96e431d0cb34d5be6cc685a580583f7859e02627666427df48aa5b
MISC metadata.xml 414 BLAKE2B b7b6cfc3dff5ca097543d0541b066c466669ea3d9193e10530e97f6992053bedb67badf78023b14893d779a1580eb3bb385d51affc5a0927d76f89ddeed1be24 SHA512 564918fba45aa79a7a05d532691fe15aaa61a0e16e6004d57875720a26fc13548d37793fbab83479d0fc8c70764b3f919430a9bd698c03c85bf9103b56355166
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.0.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.0.ebuild
new file mode 100644
index 000000000000..e3e5a9d87984
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/markdown-it-py-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest