summaryrefslogtreecommitdiff
path: root/dev-python/mdit-py-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
commit6d44cd74809cea5f81bf52ff9cd0aa902d6b6866 (patch)
tree4045142b80c7e0479c627a84e3f0de03e574df19 /dev-python/mdit-py-plugins
parent8615c518b1f1d03130f21656a1a026959bb1e9c9 (diff)
gentoo auto-resync : 07:12:2022 - 21:14:14
Diffstat (limited to 'dev-python/mdit-py-plugins')
-rw-r--r--dev-python/mdit-py-plugins/Manifest2
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.3.3.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index ed9e75baedde..a82e340bc06f 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1,5 +1,7 @@
DIST mdit-py-plugins-0.3.1.gh.tar.gz 53897 BLAKE2B 57bb08ec6f90d28beb10fbd57d980b1d6f7b1df5d5c3d537685ec1c34d2ea74ea9e5facd0ee432d12924ae2d35d32e3c4dc3600485486b6cd49d5568bffbf48f SHA512 a934953e95eba04f5c1626d8256fed53cbbb26e35d816b41b7aaf968b452e3bfaa99e3008009dbdd8d9e7c89497916916c2cc1fabbecb735624231cafee864ea
DIST mdit-py-plugins-0.3.2.gh.tar.gz 57297 BLAKE2B bc921de8a37def9239d8f67a148cd6a58449600b06abbae868256f5d5ede2d95ca8581106dd9f9ebc072b5cbe34cea60fc5472de9ba82e9ac1cb55f4910ddc43 SHA512 745b2cbcdab840f4589e0871ddb0ab43024c3dcb21bc7c40b9ff6a9c6b74117b81046fee827c358a6dd120a9c99bbcaa1a47c97a487ce21e7a37d6dcee293a5a
+DIST mdit-py-plugins-0.3.3.gh.tar.gz 57366 BLAKE2B 60b53c6aa404a22296da122b6528491fa7dc52c4b485dea1b0c26c486cd04bf495948e03c40d54ac9d436431ab1154f51af90c84762f96d87984b74718a736a9 SHA512 a32a4a7004368af924c0876106e10a55a2f361a18db127a45080779bc39fb709ca274febbb4c4d5e872357e99bd8161e6c760783793516011da5f963368fa637
EBUILD mdit-py-plugins-0.3.1.ebuild 738 BLAKE2B c6fc3bca5fe9a7fe9696eedff67021e6383f4f3bff9e2af96a28da3ec4e19ec9ded362d00c080425b173ecbcf49a9895c9d41fcbc92922ca3e5886c649c0580c SHA512 ee788989d317c63ab8a4619e4c1edf84b5ccd14fd5595a35b54b85395622e6448363a4588b7ab80741605d6a3f4d893f2ceee32844620f8645f19af8b80facdd
EBUILD mdit-py-plugins-0.3.2.ebuild 746 BLAKE2B 707776c5748a248dbdd9797049be0530c9c1fcbfe69b97cf94271ddc8ae1a9f86ccef5b623e760c0548604358c0804bfad66b6a02ef6d90fa607186234b76813 SHA512 ee174fa9bd2f7a7dbdfab4fe01fa66c6ac3db0bc937af5220023c2ba728e0218a641aaaebc1538b5da03d2be0d6993f898673bcf777c68eb4a1e4dc7eca2ab60
+EBUILD mdit-py-plugins-0.3.3.ebuild 746 BLAKE2B 707776c5748a248dbdd9797049be0530c9c1fcbfe69b97cf94271ddc8ae1a9f86ccef5b623e760c0548604358c0804bfad66b6a02ef6d90fa607186234b76813 SHA512 ee174fa9bd2f7a7dbdfab4fe01fa66c6ac3db0bc937af5220023c2ba728e0218a641aaaebc1538b5da03d2be0d6993f898673bcf777c68eb4a1e4dc7eca2ab60
MISC metadata.xml 414 BLAKE2B b7b6cfc3dff5ca097543d0541b066c466669ea3d9193e10530e97f6992053bedb67badf78023b14893d779a1580eb3bb385d51affc5a0927d76f89ddeed1be24 SHA512 564918fba45aa79a7a05d532691fe15aaa61a0e16e6004d57875720a26fc13548d37793fbab83479d0fc8c70764b3f919430a9bd698c03c85bf9103b56355166
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.3.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.3.ebuild
new file mode 100644
index 000000000000..896354240c94
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest