summaryrefslogtreecommitdiff
path: root/dev-python/mdit-py-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
commit59c2499e0c9720169c9d5a02168c51c807a21467 (patch)
tree48c68a8a7e0094b2edaace12850e6c059bc3636b /dev-python/mdit-py-plugins
parenta25cc082a26782e5d39ded4559c91ff11bc3c299 (diff)
gentoo auto-resync : 14:05:2024 - 00:01:24
Diffstat (limited to 'dev-python/mdit-py-plugins')
-rw-r--r--dev-python/mdit-py-plugins/Manifest2
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.4.1.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index c1e7f4900bd4..04b0ef6eea5b 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1,3 +1,5 @@
DIST mdit-py-plugins-0.4.0.gh.tar.gz 62199 BLAKE2B d8e69022ecceed436cd28202406bd46e786d40d3527f1c2c9311c4c32c59a4806cde9dc386309976c185522dd6286aec2542dabd31e08b8d7322fd02ae07186d SHA512 cdcce7a3819120923b7725daae0bf7a833c4da4487c49ff1a067fecf7d5e8f7a7be2fae03f3b821c766d7d6ebed4a298755ad5edb00adf73300a76a5663d67d6
+DIST mdit-py-plugins-0.4.1.gh.tar.gz 63342 BLAKE2B 3db6312e4d36cd7e870a707cbd2b99a4c954e40da2c34711a4b1f1fbd4086231f8e6013c99abdf3dc294acdfdc2706f2353151d2766223e141a0c6aa90e27996 SHA512 d2f5c59bf2a17ce441de18f815624cb6f61202f111176c5f1c7745e430d59e8690ce8a5f9da2402bd34dcc5cf4dc38377990df649fbf3256216bc82cdfc6333a
EBUILD mdit-py-plugins-0.4.0.ebuild 760 BLAKE2B dd7657adb3eb64155e2114593aabbe7142d45bc8f33643b75404ac0ffd86ec65b726ce2e9fa312f247260590c2c184ecab513d193e2b3f0621890c007eb47021 SHA512 58edcde37b0ba0b958617fb82a7c941fe6b29218740698f1020ef638c6d65d62d54bded6994f055825d726bdc666f0fa194b3709f0f5b0c51fe5af29d978d5e2
+EBUILD mdit-py-plugins-0.4.1.ebuild 768 BLAKE2B 144fe0949f781791003c620d6f121cad5c72206debfdd5603edb966f6cb4fd61a716a621667652355cfc170c7044f6f052023fb1f6d2a3d33b6a4d9657f5d850 SHA512 d34006eefd6421fac3d6b79a5bd7dd896950675e537f13533f10983e0c2b0debcc7cbb12abcf61b2c8b66b17eab8e8c129af75d23da5ddd9d444c971ccf75c4e
MISC metadata.xml 414 BLAKE2B b7b6cfc3dff5ca097543d0541b066c466669ea3d9193e10530e97f6992053bedb67badf78023b14893d779a1580eb3bb385d51affc5a0927d76f89ddeed1be24 SHA512 564918fba45aa79a7a05d532691fe15aaa61a0e16e6004d57875720a26fc13548d37793fbab83479d0fc8c70764b3f919430a9bd698c03c85bf9103b56355166
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.1.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.1.ebuild
new file mode 100644
index 000000000000..42e19e457f8b
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/markdown-it-py-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest