summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib-inline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-31 03:47:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-31 03:47:04 +0000
commita4d738a9d1fddef251ba88e258acdb50c243fa63 (patch)
tree1687346e6907f4670ab4015ff2e717c50d574f9c /dev-python/matplotlib-inline
parent77922838ba6e7b5f546528626d41f2e7f3fc2c08 (diff)
gentoo auto-resync : 31:10:2023 - 03:47:04
Diffstat (limited to 'dev-python/matplotlib-inline')
-rw-r--r--dev-python/matplotlib-inline/Manifest1
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/matplotlib-inline/Manifest b/dev-python/matplotlib-inline/Manifest
index 2cc52f8321ae..b9cdce933595 100644
--- a/dev-python/matplotlib-inline/Manifest
+++ b/dev-python/matplotlib-inline/Manifest
@@ -1,3 +1,4 @@
DIST matplotlib-inline-0.1.6.gh.tar.gz 7526 BLAKE2B fd8fde8e218e19fdf7a09bd7f36abd2e4422ed7de8ed8e2d6e52d995e76b62d8e60223fc43a243f2a0ca545037b44ead9520b67cf54b173d95389eb401b17e9a SHA512 7d34f5a86d65d7a2017cf924dc363d7578d1eb14943c3de56e5a0ac79d92d674b387c5528ea76e9e11e0193e71d8cd1315ceb517e9c9678c41ed412e8fd42c04
+EBUILD matplotlib-inline-0.1.6-r1.ebuild 1017 BLAKE2B 38781b7f9a4d8b85dacb06606232f7f1fc3c5c95a440c1ff558b318dc16d9481cef54616a8a25e0a07326bb1f5fc3e7e7d762795adedabb3abc954a57d0edec0 SHA512 e63e885ae6b3beea54eb12d953558c24b593ba9154d1b4d5eaf4eae573785d4e14b9ae3accecf0541b113eab046ea7db15a4ac9c164dab474b4e7655e5a48c7f
EBUILD matplotlib-inline-0.1.6.ebuild 631 BLAKE2B d898ae3622855e12a6d9c5e4ea32cc02a3a6ad38800d30072e1c7aeccaaa7869c3e1eaa34573f35f583610d38f8c187520d67d474b74d455e46850536964eb4c SHA512 1908fa4f7d399c8a3105e266c22c77f2f6f9886a042adc53862cf559023a3fa7e15e2ec29b8a0ce6de25624dc2201313b6f931440790779c619c2b8ac666fb52
MISC metadata.xml 388 BLAKE2B 2c15ea9d7f572bfd693b7b715ad5d32b0528889b07e7b7d2b58e2f99d1884acf376ed5bcbcf527179b232bc761c3aa31a59b112acd7b3a82f07f19d2592d167d SHA512 a40bc579234e3f6f4cb7cf12c0851ff23be0e9a2af94af099d503214f626d03a26dff3fc5d1aebedb5c3b4adfb13f1b6fb72ec10d62d3fea6bc2772271cea027
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..0803c515b454
--- /dev/null
+++ b/dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Inline Matplotlib backend for Jupyter"
+HOMEPAGE="https://github.com/ipython/matplotlib-inline/"
+SRC_URI="
+ https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+# Although in theory we could depend on matplotlib, upstream does not.
+# This is because the sole purpose of the package is to be loaded by
+# ipython (also not a dependency!) as a response to interactive use of
+# the "%matplotlib" magic.
+#
+# In order to be seamless and straightforward, this backend is always
+# installed and just requires users using matplotlib, to install
+# matplotlib before importing and using it.
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"