summaryrefslogtreecommitdiff
path: root/dev-python/marshmallow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/marshmallow
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest3
-rw-r--r--dev-python/marshmallow/marshmallow-3.0.0_beta8.ebuild35
-rw-r--r--dev-python/marshmallow/metadata.xml11
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
new file mode 100644
index 000000000000..b4187e159f3d
--- /dev/null
+++ b/dev-python/marshmallow/Manifest
@@ -0,0 +1,3 @@
+DIST marshmallow-3.0.0b8.tar.gz 148882 BLAKE2B a83e9cb2ff7d5786e5a0d5c947e578f81d7d2ab008257df195096e06031b100cd6d31bdab3df63b6ab6704268b1915827dd89f7e5fce6a638d136686fc9ebc07 SHA512 34f7a974872d0cdad828e342788269ab19194e17f30716dc8db21bc3b86ab3f1be6bd5e31c7bcbeaad7b8c70acc39eab256eb938060eff42067f5f1b3ba51c1c
+EBUILD marshmallow-3.0.0_beta8.ebuild 826 BLAKE2B 1ef671583bf696aef8441aafd5ce82cb6db7b1487263a231c4bf47dd84b0e0c0e12c567fa865de4402c85d17870a0fdc943d810f40de226ff0460fb3c1159815 SHA512 6843b3f4e527001ac81f145c97746311ffde388967e4197d33d5e2b58e23531b4ab10a9d659365b68f18be261cc797a947e990322d75b7ee4bec17a7ef7b0c51
+MISC metadata.xml 360 BLAKE2B ed1f62630b417aaefbfc1ce52c275f16187a1fac9ee46e7172c4b703452329b64de253eed111bde2e7bcb4b85e7806d8423fd5d80899f93b23e7c3da61030a2d SHA512 51665fe5adb03e70bb1582f393b95783c9e4956c24f664c09d08017663bc8373b07080c142f714fd4c93381cbd5c55bec2b58ca412df6aa55980f9a61abebc54
diff --git a/dev-python/marshmallow/marshmallow-3.0.0_beta8.ebuild b/dev-python/marshmallow/marshmallow-3.0.0_beta8.ebuild
new file mode 100644
index 000000000000..630eff899b7f
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.0.0_beta8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ rm tests/test_py3/test_utils.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test -v || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/marshmallow/metadata.xml b/dev-python/marshmallow/metadata.xml
new file mode 100644
index 000000000000..36de12026687
--- /dev/null
+++ b/dev-python/marshmallow/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">marshmallow</remote-id>
+ <remote-id type="github">marshmallow-code/marshmallow</remote-id>
+ </upstream>
+</pkgmetadata>