summaryrefslogtreecommitdiff
path: root/dev-python/marshmallow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
commit7c334a9594ae315e537bf98259b95bafc60d479c (patch)
treefc41ac024e70df2bad3160b2d02fd5a01adde46b /dev-python/marshmallow
parentd1849ceeb9c09150c11cc0d112883cfba503af27 (diff)
gentoo auto-resync : 21:07:2023 - 10:04:00
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest2
-rw-r--r--dev-python/marshmallow/marshmallow-3.20.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index fb16438bc5b2..7256995b19db 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,3 +1,5 @@
DIST marshmallow-3.19.0.gh.tar.gz 182305 BLAKE2B 2e37e0dcfcab3fa080745ccf6acbaf0fc71a43edfc9227ebf1d5320c61b0f0b51a0f3ea1d75ab1b213f8464d8ac043365ddadc8d9ab4479e21eed92ce5362b4e SHA512 e908ab33703fed5a9290189aa151dfdb425668bebe89063084f10435d2030927ce001c0d34d504d19998863431ded52a7a551085b11212489495d34aadb3b9e1
+DIST marshmallow-3.20.1.gh.tar.gz 183718 BLAKE2B f1e8011be42f6a94d8d2bfde70d2761b3a3efdbce1ca61445d11b8b1e2e2f79953abd4fcefcd9bfcb3370458c9bb0084a2697b8537af8f58d161bb0d19559170 SHA512 8d2eeadad42811b2311f70c8eb0101d88a53fa8d4216a2ab44e67a508f5514c65c35932e1d3d2000b5cbd77ee4aae2be0e29a82576c3917f5db640f4af078b53
EBUILD marshmallow-3.19.0.ebuild 780 BLAKE2B 946dac7aedefca68112cc5f4113a6e5b8ce7b57d50bb61a47e07ad4761e078b9058b88a7eac69ae6a2641283e28bb6455260a9de726392d6d3703fd8fbdfcc7f SHA512 759a1d5df428ae1ce25192412320602c3f86af6e6eb9bb472b9d3c108c326f0d489358d116124c8c57b7507c8ded32754fd5a91a8649d1f22fcf962fa3734381
+EBUILD marshmallow-3.20.1.ebuild 780 BLAKE2B 946dac7aedefca68112cc5f4113a6e5b8ce7b57d50bb61a47e07ad4761e078b9058b88a7eac69ae6a2641283e28bb6455260a9de726392d6d3703fd8fbdfcc7f SHA512 759a1d5df428ae1ce25192412320602c3f86af6e6eb9bb472b9d3c108c326f0d489358d116124c8c57b7507c8ded32754fd5a91a8649d1f22fcf962fa3734381
MISC metadata.xml 462 BLAKE2B 8092c0a0e4a28fdedd16131788e41c7133a7d114b6603c859a7b75a3e2c1519e51450c6ecd8b8bb42b16feee2b187d61a3241c4af6a4decebe85cd011944271d SHA512 bc243259fe7e0cf4892a8e9d5bc9792cdf9166400e6c5a2bb00dda58a1a4eae672c9b5c9723ba662f583bf47b994134943d6879141472e9ca4395d8700649997
diff --git a/dev-python/marshmallow/marshmallow-3.20.1.ebuild b/dev-python/marshmallow/marshmallow-3.20.1.ebuild
new file mode 100644
index 000000000000..6238f7c18ef0
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.20.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-0.17[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest