summaryrefslogtreecommitdiff
path: root/dev-python/marshmallow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-10 07:02:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-10 07:02:28 +0000
commit47f05d092ef8c19b3e973f62648e58c0e1a18631 (patch)
tree2c129dec419224136e584e8099f4ab13dadf9500 /dev-python/marshmallow
parenta2219cb0f7891a8fa42ccd9541809c62ce695216 (diff)
gentoo auto-resync : 10:01:2024 - 07:02:28
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest2
-rw-r--r--dev-python/marshmallow/marshmallow-3.20.2.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 29bb6ccfdf48..493e4ba60763 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,3 +1,5 @@
DIST marshmallow-3.20.1.gh.tar.gz 183718 BLAKE2B f1e8011be42f6a94d8d2bfde70d2761b3a3efdbce1ca61445d11b8b1e2e2f79953abd4fcefcd9bfcb3370458c9bb0084a2697b8537af8f58d161bb0d19559170 SHA512 8d2eeadad42811b2311f70c8eb0101d88a53fa8d4216a2ab44e67a508f5514c65c35932e1d3d2000b5cbd77ee4aae2be0e29a82576c3917f5db640f4af078b53
+DIST marshmallow-3.20.2.gh.tar.gz 183876 BLAKE2B 84cf8ca23069ad1d2353ffa9299556298457485fa459746b948835f04f92ef3949d5429e8285e084be7398fb294b3d74eba1b38ef21b469daed401f1e6affcdb SHA512 8305693405a976c53333b0c6ef074a12af4736f9620ca37c7c2ec6318fac2b19086426344ce8c2f515e95becdba8b2bb1c20aca5a9dffb4145cb27fee00dc080
EBUILD marshmallow-3.20.1.ebuild 780 BLAKE2B 946dac7aedefca68112cc5f4113a6e5b8ce7b57d50bb61a47e07ad4761e078b9058b88a7eac69ae6a2641283e28bb6455260a9de726392d6d3703fd8fbdfcc7f SHA512 759a1d5df428ae1ce25192412320602c3f86af6e6eb9bb472b9d3c108c326f0d489358d116124c8c57b7507c8ded32754fd5a91a8649d1f22fcf962fa3734381
+EBUILD marshmallow-3.20.2.ebuild 780 BLAKE2B 6ecc83fd5cb3f29ac1fe07116cef0f0054df5d67ecf4073492e353b00cbfe6b40f3999071207f25a4d20a1b5b9fe0212678cdfc92c9a626431a11e8fefefd72d SHA512 89303f888621dba6b13ed55351b55dc23bb5f921bf2fa8063aea7561f7764ef3061fabbb26dde07ae1ad814cd6efbfd66ba46a1efa45d59389fe020f8ea56075
MISC metadata.xml 462 BLAKE2B 8092c0a0e4a28fdedd16131788e41c7133a7d114b6603c859a7b75a3e2c1519e51450c6ecd8b8bb42b16feee2b187d61a3241c4af6a4decebe85cd011944271d SHA512 bc243259fe7e0cf4892a8e9d5bc9792cdf9166400e6c5a2bb00dda58a1a4eae672c9b5c9723ba662f583bf47b994134943d6879141472e9ca4395d8700649997
diff --git a/dev-python/marshmallow/marshmallow-3.20.2.ebuild b/dev-python/marshmallow/marshmallow-3.20.2.ebuild
new file mode 100644
index 000000000000..95b74278c863
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.20.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-0.17[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest