summaryrefslogtreecommitdiff
path: root/dev-python/marshmallow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-23 20:45:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-23 20:45:29 +0100
commit26062b5638b6d2a6eedba7797ed6dde6f3d1f01c (patch)
tree39029c21f40249c93a1ca385bf838b14e41aecae /dev-python/marshmallow
parentcdfd4f0c915964d401cba19362c7dea8e89ad1da (diff)
gentoo auto-resync : 23:08:2022 - 20:45:29
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest2
-rw-r--r--dev-python/marshmallow/marshmallow-3.17.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index b19856fb782e..cfe87fe65dd0 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,5 +1,7 @@
DIST marshmallow-3.16.0.tar.gz 180106 BLAKE2B c3d9b9c1645e7df103940b8e637f3de027f23e5da4a6ebd25412fef9d2d61483ec934af5c37f781121928a7b2f98b44793a8671173a5c548936ce0bbd0d2290d SHA512 5d3c7babff9117261afb902090bffcdba4eee2984d13862f4974fc043c6e56420707a6d3aba4a6046d947ef9414386c24895fc9a2538e36e505692e76d70f409
DIST marshmallow-3.17.0.gh.tar.gz 180037 BLAKE2B 17fa577a969d82555312b362b41e6c61c209566ba418c9aa14ef1195b7317477a9e7c7d669e5643bee0d12454fee79bcf35a9eb625ad499347299e6727afb6bc SHA512 3fceb6dcb3df7339d0c002ac90ed9960bdcc174b29ad0fc3222a435d3980b892ae07c1080483b7a5a71455a475ae1086869432cefab898a1008ad33c7efc1f99
+DIST marshmallow-3.17.1.gh.tar.gz 180094 BLAKE2B 7c4dc60923ef95bdd0d77da4d6c643193944ca02115fd12529fa564860acee3ec495f1b402f5bee6b4a90fe6100e766cc0959918aed57b232e9ff2e5d2500602 SHA512 f72f969fba2136cfe288fea93a6db791b99f163f5b5af3498c6dbef9150abd5ce66b9678b1ba6538c3add530272b13c197a57d2e35cf148a5d21bf12feafcdd4
EBUILD marshmallow-3.16.0.ebuild 687 BLAKE2B da59e69f7fe2a95e6d582589da2c1b1cc2791761e0f08a78312a2aff1cf34ff8a3ca5e64235bec0a780e6adede7137a34690a2c36c8cde0740cec6aa19366dd5 SHA512 63fc50025e89c1f9e455e094dd08556b35149cca8f61d6bed612f4a52a4c50fd638871741d15a13352eab250a30182ff3d9896f210d9709133896a176dbcbdac
EBUILD marshmallow-3.17.0.ebuild 779 BLAKE2B 13352f11149753711f397bac48d55156afbed1d60ccbb513c08890ea5ccd4cff4041d3670fd9c1d0b112425d0f1c9cff860ffb95182d6290d92af5e28595eb41 SHA512 a9bb50b6608da42e5ffb869f7e028a99a33bcdd0a91a29a9365c797e96c39a62db61cc95ac528f8a68989adadb563aa188d5b4ccdb1572aed37f53a1c685b239
+EBUILD marshmallow-3.17.1.ebuild 779 BLAKE2B 13352f11149753711f397bac48d55156afbed1d60ccbb513c08890ea5ccd4cff4041d3670fd9c1d0b112425d0f1c9cff860ffb95182d6290d92af5e28595eb41 SHA512 a9bb50b6608da42e5ffb869f7e028a99a33bcdd0a91a29a9365c797e96c39a62db61cc95ac528f8a68989adadb563aa188d5b4ccdb1572aed37f53a1c685b239
MISC metadata.xml 462 BLAKE2B 8092c0a0e4a28fdedd16131788e41c7133a7d114b6603c859a7b75a3e2c1519e51450c6ecd8b8bb42b16feee2b187d61a3241c4af6a4decebe85cd011944271d SHA512 bc243259fe7e0cf4892a8e9d5bc9792cdf9166400e6c5a2bb00dda58a1a4eae672c9b5c9723ba662f583bf47b994134943d6879141472e9ca4395d8700649997
diff --git a/dev-python/marshmallow/marshmallow-3.17.1.ebuild b/dev-python/marshmallow/marshmallow-3.17.1.ebuild
new file mode 100644
index 000000000000..f924d3b5509e
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.17.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-0.17[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest