summaryrefslogtreecommitdiff
path: root/dev-python/marshmallow/marshmallow-3.19.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-12 09:31:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-12 09:31:41 +0000
commit983485e93d76602266889d23c963609073b75e51 (patch)
tree19081a3616b34ff1d8bc5521d767740501b31153 /dev-python/marshmallow/marshmallow-3.19.0.ebuild
parent3a9a4f8b478ff62e3c752e20305edb2c7d91959f (diff)
gentoo auto-resync : 12:11:2022 - 09:31:40
Diffstat (limited to 'dev-python/marshmallow/marshmallow-3.19.0.ebuild')
-rw-r--r--dev-python/marshmallow/marshmallow-3.19.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/marshmallow/marshmallow-3.19.0.ebuild b/dev-python/marshmallow/marshmallow-3.19.0.ebuild
new file mode 100644
index 000000000000..f924d3b5509e
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.19.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-0.17[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest