summaryrefslogtreecommitdiff
path: root/dev-python/markdown2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-18 07:50:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-18 07:50:03 +0000
commitf8730c9e91ed2ce341e231c5adffb5f003f77678 (patch)
treeb4ecbb2994744fab3e10498bf64ef81d01ca550d /dev-python/markdown2
parent3e02de9a64a4e3d1f1af271a9da7ff7bbf8d86c8 (diff)
gentoo auto-resync : 18:12:2023 - 07:50:03
Diffstat (limited to 'dev-python/markdown2')
-rw-r--r--dev-python/markdown2/Manifest2
-rw-r--r--dev-python/markdown2/markdown2-2.4.12.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
index 5dfa4136c9e3..a8e9d531ef75 100644
--- a/dev-python/markdown2/Manifest
+++ b/dev-python/markdown2/Manifest
@@ -1,5 +1,7 @@
DIST markdown2-2.4.10.tar.gz 123813 BLAKE2B 4aee5ece385a6987fc9d8fccbd3141f42f6469328d0c6ddd7bfeb4bcbffb2cdf2a6375bd9fab8dbc79b099894303e94f15df334b244d877970cc5e52d2f0bf5f SHA512 1053d5e13dfe83158c7e1b87a68f12a2d5bdeddf1cae359c2992028687d18e69d71c1347ac04cbfcbcb4a6c629eeb1f465537e2e4b47c0594f0c5d175b9ce04f
DIST markdown2-2.4.11.tar.gz 128610 BLAKE2B 0418b97589be177bd3ac76d426e653f2ec48b1e12ab54d7a3e1d1e69a0f926e59fb0287f02ba9e72047ac62c0a1bc404711ad7e0e10a4aec32606d2231d32c71 SHA512 dbb7130eaf0924741694e905fc6ca8c2f0c46059c5aec144c3170b6793f2c50d2b0be90bd76f775a79e83101c3b0a549056c5e8f0ea0fed911c22ae1844b0c31
+DIST markdown2-2.4.12.tar.gz 129973 BLAKE2B a4e693a63cbb30a4c5351e3dd5974fa9750ff22ef956a5e09b53056081d2a95072b5c591f3f084913247691ffdef8c96a20bdd56b916a77a0319c663de2fada8 SHA512 db5f75b03e2056b43c4c3fde0e7b0e3d3b584d9ce2d4a71dbaf53d733c33ac20bf497bd3eb64ff3c8b4947969cf581bb50496ba189a39b8edcc9130cacb0874a
EBUILD markdown2-2.4.10.ebuild 682 BLAKE2B 8a2bc4549b2242043ff6f9b12ad6cf9fc42c3759b50d439c17ed28fb36ee4f54257a48ec1274e71dbfdf117029e67079cba00877117d146a913a99d79507a375 SHA512 661a170f31dc29f67c743fc7a8736617ee9586d8b79617ab7df327b5130bead46731ec6edddad006e1ec961d3950beaf36b4872c7f2c09910e654be6c6775208
EBUILD markdown2-2.4.11.ebuild 687 BLAKE2B 56f9f749783d4e7009ef8427c6b345b3058082b81a504128a9861abc2c6c8d444f79675bf2727ae80b1a2beeab1f6dd5849da9e399865c8da14037f86af44e68 SHA512 c4656a1c33ba7a122f9a1e3b5ea6c3ac0d481945058dbe0aa5b07dee5438f9928b3c6f8d918704868a7fbaf00a3284f3070d24e3fa287a9dfd91a580001bc9bb
+EBUILD markdown2-2.4.12.ebuild 687 BLAKE2B 56f9f749783d4e7009ef8427c6b345b3058082b81a504128a9861abc2c6c8d444f79675bf2727ae80b1a2beeab1f6dd5849da9e399865c8da14037f86af44e68 SHA512 c4656a1c33ba7a122f9a1e3b5ea6c3ac0d481945058dbe0aa5b07dee5438f9928b3c6f8d918704868a7fbaf00a3284f3070d24e3fa287a9dfd91a580001bc9bb
MISC metadata.xml 551 BLAKE2B 293046752073df3a0fe72acea3165d62ae78297f82aa72e40edeaab6bb6021ccbeaa8cc145341aa05dd3fe87c2f89e88f2281ca95ead33d99bbfc5ba53573ca1 SHA512 9d30d896754f1379f4fae79f86bec966cc3639a42e5e7bcc7e8d2e94881ee8a75b7e3ddedbc1573f1eb3c429aea636512efdb887f2827dc1b1aaa4caaa44e413
diff --git a/dev-python/markdown2/markdown2-2.4.12.ebuild b/dev-python/markdown2/markdown2-2.4.12.ebuild
new file mode 100644
index 000000000000..40066426c08c
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.4.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python Markdown language reimplementation"
+HOMEPAGE="
+ https://github.com/trentm/python-markdown2/
+ https://pypi.org/project/markdown2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pygments-2.7.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" -m unittest test_markdown2.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}