summaryrefslogtreecommitdiff
path: root/dev-python/markdown-it-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/markdown-it-py
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/markdown-it-py')
-rw-r--r--dev-python/markdown-it-py/Manifest2
-rw-r--r--dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/markdown-it-py/Manifest b/dev-python/markdown-it-py/Manifest
index 1ecc2c46d269..805ea70667d9 100644
--- a/dev-python/markdown-it-py/Manifest
+++ b/dev-python/markdown-it-py/Manifest
@@ -1,3 +1,5 @@
DIST markdown-it-py-2.0.1.gh.tar.gz 265850 BLAKE2B fe61608f14b22dffb81bb943df75967300e8366ff1b1c252b35974414efa6b2daac223b09f40ff6d7feab70c5b033b0eee35a4ee5f8523325f12311f4cbeef57 SHA512 fccf00de7e94986a29047da948d6ebb6304ae3645e79bbad480366c3aadbd417b95d96489d167a532eee3c2e17b67e22777224290564c7bcc17d72fec29b08df
+DIST markdown-it-py-2.1.0.gh.tar.gz 265858 BLAKE2B 0d1bb789ed9a8d08b16c753f7ecc7cc6a6b1fd59fc39d303a0de15276a0a0f93dc8c8bc952de60450741f26770dd3955ae0e6aaa358bacf1003e5eb9124d3a54 SHA512 04e90538c8693f795aed2ed0a5bef4eaf0c12fac32cc0c2049c563e974b229940b9ceaea849ce86fa9804ccdd7be93145f3b6fc8d0774e96fafa0484368d0a88
EBUILD markdown-it-py-2.0.1.ebuild 969 BLAKE2B b2a51e74ee4b29b4cc1ae82aaaa661c902a57f9486a3d29a218d946f113cc9efb2970baadbbb9ee7d9eebd4cf3672d57db45a6f63f155eb033dbfd42e4a9e730 SHA512 fa812a8b68adc07a48aa2f8441e74abed72853d5ee33dc0dd104fbd130f00bfd67a2149c40898fcffd03a7c72147d11466de0c96df2991b5a519da7cb0deb5ef
+EBUILD markdown-it-py-2.1.0.ebuild 971 BLAKE2B 79c7a87b050ce63e5adc08a4fefd986a72770983567634d6688d87021512c350ddec8691b79aec020a061af2444481a2a85b340a9839f8f874d46fae6bd252f4 SHA512 7b1e90d262f3e522ddf484853a02016cd5fefe5973537e05e86e41ca087cf0b250012a5624927f86a96e8030cfdcc68091e1e9a4cfca9a8fca9133c4349c0ae3
MISC metadata.xml 412 BLAKE2B bffaf51dbd0a94b09d07650e49e9bee76015ab4358c36db207713d82387a1d729e7f6576d824b02ccfd786353762e623e3dd657fb3d7c42f8467c8165da61ed3 SHA512 88b86fad883100895db6feee193102cc93ead665e1283d02f9f57a4bb228acfc738cef11af2ba02cab9b02fdfe8ba35861347a19e5b0de22f546e8e0a297e173
diff --git a/dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild b/dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild
new file mode 100644
index 000000000000..aa68ea704662
--- /dev/null
+++ b/dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1
+
+DESCRIPTION="Python port of markdown-it, Markdown parser"
+HOMEPAGE="https://pypi.org/project/markdown-it-py/
+ https://github.com/executablebooks/markdown-it-py"
+SRC_URI="
+ https://github.com/executablebooks/markdown-it-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/attrs-22[${PYTHON_USEDEP}]
+ dev-python/mdurl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Unimportant tests needing a new dep linkify
+ tests/test_linkify.py::test_token_levels
+ tests/test_port/test_fixtures.py::test_linkify
+)
+
+EPYTEST_IGNORE=(
+ # No need to benchmark
+ benchmarking/
+)