summaryrefslogtreecommitdiff
path: root/dev-python/markdown-it-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-04 09:34:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-04 09:34:05 +0100
commit13b130894803eda558b74353eda3bf7504615b38 (patch)
treeeb6788b9eeef843120928d0df4cd2b5667aeccb3 /dev-python/markdown-it-py
parent5c9bbe083a12cfb9666fed4abe5bce219ff2f019 (diff)
gentoo auto-resync : 04:06:2023 - 09:34:05
Diffstat (limited to 'dev-python/markdown-it-py')
-rw-r--r--dev-python/markdown-it-py/Manifest2
-rw-r--r--dev-python/markdown-it-py/markdown-it-py-3.0.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/markdown-it-py/Manifest b/dev-python/markdown-it-py/Manifest
index e46654a2db7d..721b992acb4f 100644
--- a/dev-python/markdown-it-py/Manifest
+++ b/dev-python/markdown-it-py/Manifest
@@ -1,3 +1,5 @@
DIST markdown-it-py-2.2.0.gh.tar.gz 266808 BLAKE2B 8eae5e1924e7afbc79203a11beb7b8271c4c524f5b26cd4bed86f784e4e811d081c2c6bf573bfcdb08f5e270c323957c439c9b9744c7036c4615daece24bde35 SHA512 84d6c15084bf33bdecdcbc8419322f2898bde20de6baeaee6c66c4e6ad9e47dfb8a14e2b1fcf71b8c42e7b61a7caed119919faf0faf6765aad85c186d91fe9d5
+DIST markdown-it-py-3.0.0.gh.tar.gz 275478 BLAKE2B ab264d6de015262e770b5da9c26a48a9fa40209119e38e12e4185aa8b5141986df62f2ff44d80c2d62732e75408b3a70bf35ae9b7ca899ae284636cc62ded710 SHA512 820265595ab650f5ac64419d5c2687d1ee361d2a0550b9d94e86ec826cfe5e89cbd69e59d6582aac41d3b95f00ce4a0b7213bf6cd590fdbd8fd9b743c7418759
EBUILD markdown-it-py-2.2.0.ebuild 854 BLAKE2B 2cbb0e5ee688502bd0e2908cf5b14ec9ce17d5223149df2d9f925a8a87d8169dd1f7c2ae2cc9ce741a901be3a6622afdc19c37469aad2f3dad839b86dc0ed0a2 SHA512 9a07b489c8a477481739e997a71104c66c76f0ce3cffcacb9a995818396e6cf06b2d7bf97310dc9f0023c0b4b66476cdcc940f6050ced08c498374e3c00a200e
+EBUILD markdown-it-py-3.0.0.ebuild 862 BLAKE2B da79be9d7387c8dee0cece86efb52d0cff67717de8eefeafdf1a940d62e64a475d5fa715e797a6bd3f9201f3e9b8ac18ba4bc9336b720512802ee33cbe465566 SHA512 f88fa16bb60ef3bb42ad6dc4577f1900efd30214e183af5607a3e6864fb553bd9eebe40dce7e3e8fc7fbdd26a2bc6933706ab846eeea1861f20310ae2c3aca1d
MISC metadata.xml 412 BLAKE2B bffaf51dbd0a94b09d07650e49e9bee76015ab4358c36db207713d82387a1d729e7f6576d824b02ccfd786353762e623e3dd657fb3d7c42f8467c8165da61ed3 SHA512 88b86fad883100895db6feee193102cc93ead665e1283d02f9f57a4bb228acfc738cef11af2ba02cab9b02fdfe8ba35861347a19e5b0de22f546e8e0a297e173
diff --git a/dev-python/markdown-it-py/markdown-it-py-3.0.0.ebuild b/dev-python/markdown-it-py/markdown-it-py-3.0.0.ebuild
new file mode 100644
index 000000000000..a8af2d10a38b
--- /dev/null
+++ b/dev-python/markdown-it-py/markdown-it-py-3.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python port of markdown-it, Markdown parser"
+HOMEPAGE="
+ https://pypi.org/project/markdown-it-py/
+ https://github.com/executablebooks/markdown-it-py/
+"
+SRC_URI="
+ https://github.com/executablebooks/markdown-it-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/linkify-it-py-3[${PYTHON_USEDEP}]
+ dev-python/mdurl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # No need to benchmark
+ benchmarking/
+)