summaryrefslogtreecommitdiff
path: root/dev-python/mapbox-vector-tile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
commitfceeb864f5e0e6155b3f5ed010298e5b7b2f1278 (patch)
treeeae9568ab98ccfbd977dade72fecdd45c670fc9d /dev-python/mapbox-vector-tile
parent517343fddd94e620e94be97ae22eca4b57dc7625 (diff)
gentoo auto-resync : 18:02:2023 - 08:10:15
Diffstat (limited to 'dev-python/mapbox-vector-tile')
-rw-r--r--dev-python/mapbox-vector-tile/Manifest3
-rw-r--r--dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild35
-rw-r--r--dev-python/mapbox-vector-tile/metadata.xml16
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/mapbox-vector-tile/Manifest b/dev-python/mapbox-vector-tile/Manifest
new file mode 100644
index 000000000000..e4da8e85043a
--- /dev/null
+++ b/dev-python/mapbox-vector-tile/Manifest
@@ -0,0 +1,3 @@
+DIST mapbox-vector-tile-2.0.1.gh.tar.gz 229202 BLAKE2B 9afa12583f1f2697c8fd3a7ad540851c2b3ea7bca26bf7945aa52ad9c2486f4b6ec0a0bc84e750e18ecb55a51558659284d52efedcb724ec5de98f965d78b954 SHA512 67648c27792557a5e011732c31f8a0a3e6efca8630086e55e6fdc433953b820ef6405031d10692999026c604f3977eb00bafa9a1a7015f02c3dca87ca91eadf6
+EBUILD mapbox-vector-tile-2.0.1.ebuild 884 BLAKE2B 8e49511151e7ea019b4fe07d0e397576ecf10532c2e1411346cd366930fc9c270f26b6c30b541b5fb383ce9a5a99bd283a52ca2561e5930a19c668453ccc2914 SHA512 f81507a4f4a2adc0fc700e303cbad6e3d5e0384d41745063e47701f370c74e4b80754810ec2adc0c3e81d22f82306c0798537d764a2b13b47ff3fc6c61a85d76
+MISC metadata.xml 564 BLAKE2B 48abaac3aae8007371f0fbfbe58910d820857a2231161c4ba2732509f3b1143cc3ba34094222ed7b8d45202b7f79ca36b5a2f24eaf572fdd1f949caa4c972a0f SHA512 09debdc5a9d7e80b19e7f64bbb4b560482efe294761f5d15b582c144c02b385fd2dfeefe912428d692ce5da916528f099f651a5be9f181435524ad066bb76e88
diff --git a/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild
new file mode 100644
index 000000000000..09c1d2ed9048
--- /dev/null
+++ b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Mapbox Vector Tile encoding and decoding."
+HOMEPAGE="
+ https://github.com/tilezen/mapbox-vector-tile/
+ https://pypi.org/project/mapbox-vector-tile/
+"
+SRC_URI="https://github.com/tilezen/mapbox-vector-tile/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pyclipper[${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( ${RDEPEND} )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Dont install into top-level
+ sed -Ei '/include = \[/,/\]/ { /(README|CHANGELOG)/d }' pyproject.toml || die
+ default
+}
diff --git a/dev-python/mapbox-vector-tile/metadata.xml b/dev-python/mapbox-vector-tile/metadata.xml
new file mode 100644
index 000000000000..23ccc90b6e95
--- /dev/null
+++ b/dev-python/mapbox-vector-tile/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tilezen/mapbox-vector-tile</remote-id>
+ <remote-id type="pypi">mapbox-vector-tile</remote-id>
+ </upstream>
+</pkgmetadata>