summaryrefslogtreecommitdiff
path: root/dev-python/mando
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/mando
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/mando')
-rw-r--r--dev-python/mando/Manifest2
-rw-r--r--dev-python/mando/mando-0.6.4.ebuild28
2 files changed, 8 insertions, 22 deletions
diff --git a/dev-python/mando/Manifest b/dev-python/mando/Manifest
index f9cf784ee333..0e00494df2db 100644
--- a/dev-python/mando/Manifest
+++ b/dev-python/mando/Manifest
@@ -1,3 +1,3 @@
DIST mando-0.6.4.tar.gz 36560 BLAKE2B 9878746485d4b896c3e32512b77ac02739940a1398eee12056fd6719cc3c99f8c526c8e573d2556b6a9d0d8d26e20fb45c97119e626b1d44f0a5b5f4655adba1 SHA512 457fa0db4e8e5dbfac6146d254181213814ef1975c919b4573007face27749ec3a50eda850558ebdc0fdff94a5e9819fd825b10cb3023078b2b426c2825fdbf0
-EBUILD mando-0.6.4.ebuild 1073 BLAKE2B bbcf1e5995d52c9aa302f01470d6d32d70b0889f43287ec8663ad211185c8d3a687dafad2747614a39a96dd8dd18ef131b1cf69c95770aa4b9e7c6cf6a5231df SHA512 02d3649be938e2edfab1602b564f9dc00debc9402d468a2977f9929eaa8f8ff2450a1b6253f8c189cd6414d80265c62dd6ced9e5ce0989e005adf1143f019393
+EBUILD mando-0.6.4.ebuild 757 BLAKE2B 6ae109b43c0a14d95b0258fa2e9656ccc7a1479cda20d7ef73d473b6b9d91f11b4ea0dc847be58dc3e9b8cb7ab73630ab476daa7106ebb0e261e01fe89cc9cf5 SHA512 e3ef88cd92a2615c5edb844c045874d34ee5f329bbdd8d494d0f6553ec69a15a766597bc24f752198cd8e9bfa76e395e1f3a1e6b3b3a69b80a1e29953d1b2289
MISC metadata.xml 284 BLAKE2B 2ac79590ac3d86444a048221b350828e6b8ab5c575144eb2bdd5aaa9838b10d5bdb9fc1ff94df85b0912ed1e540185e1f232ad329768470fa544178cd0fccc15 SHA512 5dea54f42d9854c6e4ef70112a31c073e18ccc6af76ba95bfd72cd370e2bc720b564935abfd73c8d3c743361f824a608ba99bf848ed8da222cfaf83076403e8a
diff --git a/dev-python/mando/mando-0.6.4.ebuild b/dev-python/mando/mando-0.6.4.ebuild
index ddd3921f30cf..87d54e40707e 100644
--- a/dev-python/mando/mando-0.6.4.ebuild
+++ b/dev-python/mando/mando-0.6.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -13,30 +13,16 @@ SRC_URI="https://github.com/rubik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/tox[${PYTHON_USEDEP}]
- )
-"
-RDEPEND=""
-
-python_compile_all() {
- use doc && emake -C docs html
-}
+IUSE="examples"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
python_test() {
- "${PYTHON}" mando/tests/run.py || die "tests failed under ${EPYTHON}"
+ "${EPYTHON}" mando/tests/run.py || die "tests failed under ${EPYTHON}"
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples