summaryrefslogtreecommitdiff
path: root/dev-python/mando
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/mando
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/mando')
-rw-r--r--dev-python/mando/Manifest4
-rw-r--r--dev-python/mando/mando-0.3.2.ebuild5
-rw-r--r--dev-python/mando/mando-0.6.4.ebuild46
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/mando/Manifest b/dev-python/mando/Manifest
index 656200c0eafb..1036adba4baa 100644
--- a/dev-python/mando/Manifest
+++ b/dev-python/mando/Manifest
@@ -1,3 +1,5 @@
DIST mando-0.3.2.tar.gz 22393 BLAKE2B bf6a7df4a6e2e8270d0b8fa278cde7d520bf5c9d490dec748927d8f7c024381094f946e5feb4b5334b0d7255df002aeb1b42b8545b7514194425e37f739d2da9 SHA512 57f5041ad175c4eca4c158d9d917dcb1f9c25978c60aa0e76322d0395b0edbc3fb7b062da7b9af871a97bbd46cfe7f81e634287f813baf15ef134be53150bd11
-EBUILD mando-0.3.2.ebuild 934 BLAKE2B 48e18b3273be1f7e1a7e8e787ead47afdaadb3581de28df0af9e3af8760ae0a56ce4ac8755a0fe623a05cea633e9a944588b62aab6f0fb699be775e453bb9a52 SHA512 a1bd06368f848d4076d3c5b0c96d5cb0ddab6c80942b5ef9c65d7b63ecf57d3d6f514ffd625f0238ca9ae82207127b8658ccf802ea936b0bb1f2729c44ca6d76
+DIST mando-0.6.4.tar.gz 36560 BLAKE2B 9878746485d4b896c3e32512b77ac02739940a1398eee12056fd6719cc3c99f8c526c8e573d2556b6a9d0d8d26e20fb45c97119e626b1d44f0a5b5f4655adba1 SHA512 457fa0db4e8e5dbfac6146d254181213814ef1975c919b4573007face27749ec3a50eda850558ebdc0fdff94a5e9819fd825b10cb3023078b2b426c2825fdbf0
+EBUILD mando-0.3.2.ebuild 980 BLAKE2B c577a7b28709587033e0f1eb880fbb4158fd20ca24e9cd8d20880d5a3f430ad04766a27140c29d904a2fab2a9ce579c86ed0cf2835f8e1e4bba4da8df855661f SHA512 1774e211b5067a12162f91f0653bd64cbf90d9a91342696abe71b6e6977482fd8d8059030abf51293dc32a7aaa161c5bd6b6dcfb20a6d3c8c1da002761dd23a2
+EBUILD mando-0.6.4.ebuild 1075 BLAKE2B 10bef0608169294ecb7b4a401ee4e3d717190be854cb1889f4dfad437bdb88d7bad7455d30e3d56a398b0d3aa7264e4b8f0795a62be75fdd9671a8991297c893 SHA512 020a6b52299fd794490f87c77c8dc3b4c224c1079c5efb04cc73bee5cb9c047854b3def8c03a3c477afd74bbc4610ed5a4d2b3252b0ac883c41192c0b1aabaa0
MISC metadata.xml 241 BLAKE2B cbc5b40c8cc94046b0c3f22ff09d1d4808cbb26026213495d792da8c605df005a5670fd55586aee9ec26e66862695768683dce22127e5af344ea529302b4cd31 SHA512 3ac90d64a94a1c32453b3fe9e3fbde47602aa1257f1a15bb08e8d5c1abf779eef08378376ab4910904a672fc66b1b36f781f1ab144eea0be3c1d36f35ea6337c
diff --git a/dev-python/mando/mando-0.3.2.ebuild b/dev-python/mando/mando-0.3.2.ebuild
index 6eb96d61546e..5e16ff3b6b0d 100644
--- a/dev-python/mando/mando-0.3.2.ebuild
+++ b/dev-python/mando/mando-0.3.2.ebuild
@@ -33,7 +33,10 @@ python_test() {
python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
distutils-r1_python_install_all
}
diff --git a/dev-python/mando/mando-0.6.4.ebuild b/dev-python/mando/mando-0.6.4.ebuild
new file mode 100644
index 000000000000..6beb7fda2860
--- /dev/null
+++ b/dev-python/mando/mando-0.6.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create Python CLI apps with little to no effort at all!"
+HOMEPAGE="https://mando.readthedocs.org/ https://github.com/rubik/mando"
+SRC_URI="https://github.com/rubik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" mando/tests/run.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}