summaryrefslogtreecommitdiff
path: root/dev-python/mando
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/mando
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/mando')
-rw-r--r--dev-python/mando/Manifest2
-rw-r--r--dev-python/mando/mando-0.7.1.ebuild18
2 files changed, 15 insertions, 5 deletions
diff --git a/dev-python/mando/Manifest b/dev-python/mando/Manifest
index 0c56a85c72be..e64f8729ab31 100644
--- a/dev-python/mando/Manifest
+++ b/dev-python/mando/Manifest
@@ -1,3 +1,3 @@
DIST mando-0.7.1.gh.tar.gz 37802 BLAKE2B 1caf437248f1b1397888674fff0171680fd1d2cffd1d3394869edce4fef0d214fb52fc0eb7435ef162722f128f129f8d19385e65661914c51f78108b64f8db38 SHA512 a25dfd57e833416cbd64933ca3970712d28c2e2ed172091a0d0c082f486c707d0061afb071e3973e7e42b654d1a6e70f4909b1254fdef493471dc0ae9d3eb62b
-EBUILD mando-0.7.1.ebuild 800 BLAKE2B b49fe78b12095471f8336585ca01dcfa9e6bd413b9f3c20a9952f7226612f83d25dd5734edd9fd4757b5370be75ad7ab52aea1a83a087e47a892044171e756d0 SHA512 7e9ef108165fed7a8e849a757a6a9f8b98055f5f3f71b45ae2c18b8f5a15a1cd0ce43bc3d4cdce3f210a43d3de2a987e9e306c60f73678a304d2ec9c0c799448
+EBUILD mando-0.7.1.ebuild 846 BLAKE2B 97bd2ee4a13b684da0a8de20a9008ef5f2a8669fc7af5dfd3e1bf2673060497ccc331d2766a61bb9cbd6ad05035674679014b333d8137bbc2c8aa3119cbd6e1d SHA512 ca963ab0408992d286a9f19ab59127364de5e92d1f9122f2f2c1cee73a12cc1015a1b9721deb4113c92790fa303432c64636f12033a15aa8575036eb8e7c88f0
MISC metadata.xml 285 BLAKE2B 3f0f1cbd9283919ed3b4fb89de7ce5a23a535844ca1d04dd416f2a9d7d64ebcd84a8f89736c56452418014c4574bc4cb75156038f100eb87b5f7ad663be5ca38 SHA512 78b7d0ede36474cdd7d887cc2d74b69ff28f4c2ddf3f8dd449396b454dd48308e1ac912331b8f03aff18ebcd0168f656dc1affdda0f88dbcfb39dd14ba2a7d42
diff --git a/dev-python/mando/mando-0.7.1.ebuild b/dev-python/mando/mando-0.7.1.ebuild
index 79d654424d5b..c86ae3090eb8 100644
--- a/dev-python/mando/mando-0.7.1.ebuild
+++ b/dev-python/mando/mando-0.7.1.ebuild
@@ -4,19 +4,29 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="Create Python CLI apps with little to no effort at all!"
-HOMEPAGE="https://mando.readthedocs.io/ https://github.com/rubik/mando/"
-SRC_URI="https://github.com/rubik/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://mando.readthedocs.io/
+ https://github.com/rubik/mando/
+ https://pypi.org/project/mando/
+"
+SRC_URI="
+ https://github.com/rubik/mando/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="examples"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
distutils_enable_sphinx docs
distutils_enable_tests pytest