summaryrefslogtreecommitdiff
path: root/dev-python/mando/mando-0.6.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/mando/mando-0.6.4-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/mando/mando-0.6.4-r1.ebuild')
-rw-r--r--dev-python/mando/mando-0.6.4-r1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/mando/mando-0.6.4-r1.ebuild b/dev-python/mando/mando-0.6.4-r1.ebuild
deleted file mode 100644
index fc242ec831da..000000000000
--- a/dev-python/mando/mando-0.6.4-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Create Python CLI apps with little to no effort at all!"
-HOMEPAGE="https://mando.readthedocs.io/ https://github.com/rubik/mando/"
-SRC_URI="https://github.com/rubik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_test() {
- "${EPYTHON}" mando/tests/run.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}